aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-20 18:42:15 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-20 19:41:34 +0200
commit6779ae27e62ab390b970944c74fb910028a40530 (patch)
treefd09def4b86bf82bb7e89f657f8f4089411e8fd7 /gnu/packages/video.scm
parentf71ce2824d8838109c7ad812f4284de16a3b0afc (diff)
downloadguix-6779ae27e62ab390b970944c74fb910028a40530.tar
guix-6779ae27e62ab390b970944c74fb910028a40530.tar.gz
gnu: Add ffms2.
* gnu/packages/video.scm (aegisub): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c1856b62f3..0605c1467e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2385,3 +2385,33 @@ tables")
generation of MPEG TS and DVB PSI tables according to standards ISO/IEC 13818s
and ITU-T H.222.0.")
(license license:lgpl2.1)))
+
+(define-public ffms2
+ (package
+ (name "ffms2")
+ (version "2.23")
+ (home-page "https://github.com/FFMS/ffms2/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vbkab8vrplxz5xgag8ggzkwp4f7nf285pd0l2a7zy66n6i2m6xh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list "--enable-avresample")))
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("ffmpeg" ,ffmpeg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Cross-platform wrapper around ffmpeg/libav")
+ (description
+ "FFMpegSource is a wrapper library around ffmpeg/libav that allows
+programmers to access a standard API to open and decompress media files.")
+ ;; sources are distributed under a different license that the binary.
+ ;; see https://github.com/FFMS/ffms2/blob/master/COPYING
+ (license license:gpl2+))); inherits from ffmpeg