aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2023-08-18 16:52:46 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 16:22:04 -0400
commitf1df78959a18aa1aed07e885051514938bd1fa92 (patch)
tree5e906f8d5f8f58b3c77b7ea8edd575d7e2b86ce8 /gnu/packages/version-control.scm
parent33e300508947d831b1d63c018e92325ae4c4f959 (diff)
downloadguix-f1df78959a18aa1aed07e885051514938bd1fa92.tar
guix-f1df78959a18aa1aed07e885051514938bd1fa92.tar.gz
gnu: Add qgit.
* gnu/packages/version-control.scm (qgit): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cf3c4d4e19..248dc33171 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -79,6 +79,7 @@
#:use-module (guix build-system go)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
#:use-module (gnu packages apr)
#:use-module (gnu packages autotools)
@@ -1295,7 +1296,7 @@ and additionally allows you to access the Git repository more directly using
either a pure Python implementation, or the faster, but more resource intensive
@command{git} command implementation.")
(license license:bsd-3)))
-
+
(define-public savane
(package
(name "savane")
@@ -3552,6 +3553,40 @@ has tools for tagging, merging, checking in/out, and other user operations.
TkDiff is included for browsing and merging your changes.")
(license license:gpl2+)))
+(define-public qgit
+ (package
+ (name "qgit")
+ (version "2.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tibirna/qgit")
+ (commit (string-append "qgit-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10j5xll7ai1rb2ybyblbgqm762bqspffpf33fdr61qdchnp2gkf4"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:tests? #f)) ;no tests
+ (propagated-inputs
+ (list git))
+ (home-page "https://github.com/tibirna/qgit")
+ (synopsis "Graphical front-end for git")
+ (description
+ "Qgit is a graphical front-end for git, with features to:
+@itemize
+@item view revisions, diffs, files history, files annotation and archive tree,
+@item commit changes visually cherry picking modified files,
+@item apply or save patch series from selected commits, drag and drop commits,
+@item associate commands sequences, scripts and anything else executable to a
+ custom action,
+@item push/pop commits,
+@item apply/save/create patches
+@item and cherry pick single modified files.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public git-filter-repo
(package
(name "git-filter-repo")