aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-27 17:41:31 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-31 18:00:37 +0800
commit6bd20f880c371108e41170c55498284f7022dcbc (patch)
tree9f7cbde5e0ccf99f28f22a391b4f436fc822f1e2 /gnu/packages/version-control.scm
parent5078e98cf3d09e761d60e51eb3fbae88ea3d12f3 (diff)
downloadguix-6bd20f880c371108e41170c55498284f7022dcbc.tar
guix-6bd20f880c371108e41170c55498284f7022dcbc.tar.gz
gnu: cssc: Fix tests.
* gnu/packages/version-control.scm (cssc)[arguments]: Replace egrep with grep -E in the precheck phase.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 699a091642..1ca3dc9a53 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2377,6 +2377,15 @@ reviewing large, complex patch files.")
(substitute* "tests/prt/all-512.sh"
(("/bin/sh") (which "sh")))
+ (for-each
+ (lambda (file)
+ (substitute* file (("egrep") "grep -E")))
+ '("tests/common/test-common"
+ "tests/admin/comment.sh"
+ "tests/cdc/2comment.sh"
+ "tests/cdc/4order.sh"
+ "tests/get/subst.sh"))
+
;; XXX: This test has no hope of passing until there is a "nogroup"
;; entry (or at least some group to which the guix builder does
;; not belong) in the /etc/group file of the build environment.