aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commitdc11d823566b1d8001303c0c93378319a6fb06ed (patch)
tree393fcbb280388ba90a7dc5e1c33f921a340ae978 /gnu/packages/tryton.scm
parent3044c97b6465b798acbd28a75884ccc8341c0670 (diff)
downloadguix-dc11d823566b1d8001303c0c93378319a6fb06ed.tar
guix-dc11d823566b1d8001303c0c93378319a6fb06ed.tar.gz
gnu: Add trytond-web-shop.
* gnu/packages/tryton.scm (trytond-web-shop): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 5b6cfa0e27..eaa0c3258b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4378,3 +4378,33 @@ user instead of groups. A Role is defined by a set of groups. When a role is
added to a user, it overrides the existing groups. A role can be added to a
user for a period of time only.")
(license license:gpl3+)))
+
+(define-public trytond-web-shop
+ (package
+ (name "trytond-web-shop")
+ (version "6.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_web_shop" version))
+ (sha256
+ (base32 "0gnq9hyx4x681hcmqsm2d6rga7chbaf2r2k2nmnkjq6izg5ivas2"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "web_shop"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-product-attribute" ,trytond-product-attribute)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-company" ,trytond-company)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-product" ,trytond-product)
+ ("trytond-sale" ,trytond-sale)
+ ("trytond-stock" ,trytond-stock)
+ ("trytond-web-user" ,trytond-web-user)))
+ (home-page "https://docs.tryton.org/projects/modules-web-shop")
+ (synopsis "Tryton module that provides a common base for webshops")
+ (description "The @emph{Web Shop} Tryton module facilitates storing
+configuration of an online web shop.")
+ (license license:gpl3+)))