aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:51 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commit32b67eef8248977de8e2d83dae88e25ea627fdf1 (patch)
treeeb921865f9e349a2c03209fe7a1b16ff5e339e2b /gnu/packages/tryton.scm
parentebfc61d1daab87929768e9037bd836b70f95ad65 (diff)
downloadguix-32b67eef8248977de8e2d83dae88e25ea627fdf1.tar
guix-32b67eef8248977de8e2d83dae88e25ea627fdf1.tar.gz
gnu: Add trytond-stock-lot-unit.
* gnu/packages/tryton.scm (trytond-stock-lot-unit): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index b1cc3b9ef1..95be3eda7e 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3912,6 +3912,32 @@ the shelf life of a lot expires in less than the configured shelf life delay,
it is no more used to compute the forecast quantity of the stock.")
(license license:gpl3+)))
+(define-public trytond-stock-lot-unit
+ (package
+ (name "trytond-stock-lot-unit")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_lot_unit" version))
+ (sha256
+ (base32 "1acvrj9af83gmfcp7kgyi37kv3v5910rh1q73scd37xbv7h8dyrm"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_lot_unit"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-production" ,trytond-production)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product" ,trytond-product)
+ ("trytond-stock" ,trytond-stock)
+ ("trytond-stock-lot" ,trytond-stock-lot)))
+ (home-page "https://docs.tryton.org/projects/modules-stock-lot-unit")
+ (synopsis "Tryton module to define unit on stock lot")
+ (description "The @emph{Stock Lot Unit} Tryton module allows to define a
+unit and quantity on stock lot.")
+ (license license:gpl3+)))
+
(define-public trytond-stock-supply
(package
(name "trytond-stock-supply")