aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:36 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commit01e5dc52f7fef06b1e58114fc1d4d2eb3b71529a (patch)
treef8ebd30dd241456fb9128a9033219909e31a9cb4 /gnu/packages/tryton.scm
parentba41f4ef6f522e3c2ffd8a3f921ff890a116ed35 (diff)
downloadguix-01e5dc52f7fef06b1e58114fc1d4d2eb3b71529a.tar
guix-01e5dc52f7fef06b1e58114fc1d4d2eb3b71529a.tar.gz
gnu: Add trytond-sale.
* gnu/packages/tryton.scm (trytond-sale): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 0e46b01ae0..c8dc31489b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2969,6 +2969,40 @@ the product with its factor against the purchase unit.")
shipment costs to Supplier Shipment.")
(license license:gpl3+)))
+(define-public trytond-sale
+ (package
+ (name "trytond-sale")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_sale" version))
+ (sha256
+ (base32 "0wk5lhj74vl7zs4l3x176iwfqr3jnq37xhiksgnajsrjrl54bgfg"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "sale"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-account-invoice" ,trytond-account-invoice)
+ ("trytond-account-invoice-stock" ,trytond-account-invoice-stock)
+ ("trytond-account-product" ,trytond-account-product)
+ ("trytond-company" ,trytond-company)
+ ("trytond-country" ,trytond-country)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-party" ,trytond-party)
+ ("trytond-product" ,trytond-product)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page "https://docs.tryton.org/projects/modules-sale")
+ (synopsis "Tryton module for sale")
+ (description "The @emph{Sale} Tryton module helps organise and manage
+sales made by the company. It adds the concept of a sale to Tryton and allows
+it to be tracked through its states from draft to done. It also oversees the
+creation of customer shipments and invoices for the sales, and allows reports
+to be generated that contain aggregated sales figures.")
+ (license license:gpl3+)))
+
(define-public trytond-stock
(package
(name "trytond-stock")