aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tree-sitter.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-06-17 18:05:15 +0800
committerHilton Chain <hako@ultrarare.space>2023-08-20 22:11:44 +0800
commit78748c619a533bd23a8fc55e2a705ed23567c72e (patch)
tree453f4b5800d71d3d12866507d3216e9863534af7 /gnu/packages/tree-sitter.scm
parentab794059891e378db63b714fc2125048354283b5 (diff)
downloadguix-78748c619a533bd23a8fc55e2a705ed23567c72e.tar
guix-78748c619a533bd23a8fc55e2a705ed23567c72e.tar.gz
gnu: Add tree-sitter-meson.
* gnu/packages/tree-sitter.scm (tree-sitter-meson): New variable. Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages/tree-sitter.scm')
-rw-r--r--gnu/packages/tree-sitter.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 0c1ad7d7ed..4b191d4978 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -535,6 +536,18 @@ will be used in description and synopsis."
"0.7.1"
#:repository-url "https://github.com/ikatyang/tree-sitter-markdown"))
+(define-public tree-sitter-meson
+ ;; tag 1.2 is Aug 24,2022 this commit is Feb 28,2023
+ (let ((commit "3d6dfbdb2432603bc84ca7dc009bb39ed9a8a7b1")
+ (revision "0"))
+ (tree-sitter-grammar
+ "meson" "Meson"
+ "1rn7r76h65d41354czyccm59d1j9nzybcrjvjh934lpr59qrw61m"
+ (git-version "1.2" revision commit)
+ #:repository-url "https://github.com/Decodetalkers/tree-sitter-meson"
+ #:commit commit
+ #:license license:expat)))
+
(define-public tree-sitter-org
;; There are a lot of additions, the last tag was placed a while ago
(let ((commit "081179c52b3e8175af62b9b91dc099d010c38770")