aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tmux.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-05-11 21:47:15 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-02 16:25:44 +0200
commitd756564db5ee46b27ef65d226d16dbb8354e424e (patch)
tree0ccbc1d07b39f1d647f15255fb876fecf75c0062 /gnu/packages/tmux.scm
parentdbbc7e946131ba257728f1d05b96c4339b7ee88b (diff)
downloadguix-d756564db5ee46b27ef65d226d16dbb8354e424e.tar
guix-d756564db5ee46b27ef65d226d16dbb8354e424e.tar.gz
gnu: Add tmux-plugin-mem-cpu-load.
* gnu/packages/tmux.scm (tmux-plugin-mem-cpu-load): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tmux.scm')
-rw-r--r--gnu/packages/tmux.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 67ce18fea1..55b7c7a498 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -30,6 +30,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix build-system python)
@@ -317,3 +318,30 @@ Optional:
@end itemize")
(home-page "https://github.com/tmux-plugins/tmux-resurrect/")
(license license:expat))))
+
+(define-public tmux-plugin-mem-cpu-load
+ (package
+ (name "tmux-plugin-mem-cpu-load")
+ (version "3.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thewtex/tmux-mem-cpu-load")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "03bax7g9jlsci44ccs50drh617ya3fzvlplwyvxfyb7mgmh85r72"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (synopsis "CPU, RAM, and load monitor for use with tmux")
+ (description "This package provides a lightweight program for system
+monitoring in the status line of tmux.
+
+The memory monitor displays the used and available memory.
+
+The CPU usage monitor outputs a percent CPU usage over all processors. It
+also displays a textual bar graph of the current percent usage.
+
+The system load average is also displayed.")
+ (home-page "https://github.com/thewtex/tmux-mem-cpu-load")
+ (license license:asl2.0)))