aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-18 19:59:59 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:24:29 -0400
commitf2107eb221ee6d904c1fd05e5fcdbe064ac44b89 (patch)
tree0a26795751337a856d78f4a71e86edf128c1b129 /gnu/packages/tls.scm
parentaa2eab0fd51b3a3852dad0a90c241fe8d409a1ce (diff)
downloadguix-f2107eb221ee6d904c1fd05e5fcdbe064ac44b89.tar
guix-f2107eb221ee6d904c1fd05e5fcdbe064ac44b89.tar.gz
gnu: gnutls: Extend test timeout on powerpc-linux.
* gnu/packages/tls.scm (gnutls)[arguments]: When building for powerpc-linux add a phase to extend the test timeout.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a5154df573..e0da7757e0 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -252,7 +252,14 @@ living in the same process.")
(lambda _
(substitute* "tests/fastopen.sh"
(("^unset RETCODE")
- "exit 77\n")))) ;skip
+ "exit 77\n")) ;skip
+ #$@(if (target-ppc32?)
+ ;; https://gitlab.com/gnutls/gnutls/-/issues/1354
+ ;; Extend the test timeout from the default of 20 * 1000
+ #~((add-after 'unpack 'increase-test-timeout
+ (lambda _
+ (setenv "GNUTLS_TEST_TIMEOUT" "60000"))))
+ #~())))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
;; Copy the 4.1 MiB of section 3 man pages to "doc".
@@ -263,18 +270,18 @@ living in the same process.")
(mkdir-p mandir)
(copy-recursively oldman mandir)
(delete-file-recursively oldman)))))))
- (outputs '("out" ;4.4 MiB
+ (outputs '("out" ;4.4 MiB
"debug"
- "doc")) ;4.1 MiB of man pages
+ "doc")) ;4.1 MiB of man pages
(native-inputs
(append (list pkg-config texinfo which
- util-linux) ;one test needs 'setsid'
+ util-linux) ;one test needs 'setsid'
(if (hurd-target?)
'()
(list net-tools
- iproute ;for 'ss'
- socat ;several tests rely on it
- datefudge)))) ;tests rely on 'datefudge'
+ iproute ;for 'ss'
+ socat ;several tests rely on it
+ datefudge)))) ;tests rely on 'datefudge'
(inputs (list libunistring))
(propagated-inputs
;; These are all in the 'Requires.private' field of gnutls.pc.