aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-30 02:00:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-30 02:00:00 +0100
commite0b9cd7cc167e6033b2e51536a00d2aa1409c373 (patch)
tree4f689ab9f443fd40c1706814318ee7f8e4e8c620 /gnu/packages/tls.scm
parent807bfe55dc382b88ab0fdade6886dfa2b15487ee (diff)
downloadguix-e0b9cd7cc167e6033b2e51536a00d2aa1409c373.tar
guix-e0b9cd7cc167e6033b2e51536a00d2aa1409c373.tar.gz
gnu: openssl: Update to 3.0.7 [fixes CVE-2022-3786, CVE-2022-3602].
* gnu/packages/tls.scm (openssl): Update to 3.0.7.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index b5926f35ad..9d9f46da51 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -618,7 +618,7 @@ OpenSSL for TARGET."
(define-public openssl-3.0
(package
(inherit openssl-1.1)
- (version "3.0.5")
+ (version "3.0.7")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -631,7 +631,7 @@ OpenSSL for TARGET."
(patches (search-patches "openssl-3.0-c-rehash-in.patch"))
(sha256
(base32
- "0yja085lygkdxbf4k4rckkj9r24p8dgix8avqljnbbbixydqszda"))))
+ "0virbkcrw7nn3gr5r51z722gs1ppig0casj0c9pnj3i65829s143"))))
(arguments
(substitute-keyword-arguments (package-arguments openssl-1.1)
((#:phases phases '%standard-phases)