aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/time.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
downloadguix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.tar
guix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.tar.gz
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index dce37f3df4..cb89d04bf5 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -285,6 +285,7 @@ datetime module, available in Python 2.3+.")
"1wg3f3imjq3snvjccv64h5498pqv9xz664xhni7bsh8mnay91p83"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-dateutil python-pytz))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/jmcantrell/python-dateutils")
(synopsis "Various utilities for working with date and datetime objects")
(description
@@ -368,7 +369,7 @@ Python datetime objects.")
;; It's optional, remove this constrain where python-pytz is updated.
#:test-flags #~(list "-k" "not test_with_pytz")))
(native-inputs
- (list python-poetry-core python-pytest))
+ (list python-poetry-core python-pytest python-setuptools))
(propagated-inputs
(list python-cffi python-h3-3 python-numba python-numpy python-pytz))
(home-page "https://timezonefinder.michelfe.it/gui")