aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorJaeme Sifat <jaeme@runbox.com>2023-12-23 17:36:46 -0500
committerMathieu Othacehe <othacehe@gnu.org>2023-12-25 17:44:47 +0100
commitf6817e71dff7d0d9fdb55db8b85a1d3d04e2bf5a (patch)
tree5aca258d3649e4aa40abeaf373197341a2eef934 /gnu/packages/text-editors.scm
parent0d13d095420861022e68e87ceebd5e037e12a8b3 (diff)
downloadguix-f6817e71dff7d0d9fdb55db8b85a1d3d04e2bf5a.tar
guix-f6817e71dff7d0d9fdb55db8b85a1d3d04e2bf5a.tar.gz
gnu: Remove ed.scm.
Remove ed.scm and move the `ed' package to text-editors.scm. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove ed.scm from build. * gnu/packages/ed.scm: Delete file. * gnu/packages/text-editors.scm (ed): New variable. [copyright header]: Transfer copyright notices from ed.scm to text-editors.scm. Change-Id: I827a2943f4849085186f2a25a9c8676cf4b6a7fd Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index f5714e934a..3614d6c31c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -1,6 +1,9 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2016, 2019, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2020, 2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
;;; Copyright © 2017 Nikita <nikita@n0.is>
@@ -24,6 +27,7 @@
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;; Copyright © 2023 Eidvilas Markevičius <markeviciuseidvilas@gmail.com>
;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +66,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages code)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crates-io)
#:use-module (gnu packages curl)
@@ -102,6 +107,37 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public ed
+ (package
+ (name "ed")
+ (version "1.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/ed/ed-"
+ version ".tar.lz"))
+ (sha256
+ (base32
+ "0krb8rsb0cd8mgz0c5pqgnjbbrj7zjl7mf9099r8gi80k2nyza5c"))))
+ (build-system gnu-build-system)
+ (native-inputs (list lzip))
+ (arguments
+ `(#:configure-flags (list ,(string-append "CC=" (cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'patch-source-shebangs 'patch-test-suite
+ (lambda _
+ (substitute* "testsuite/check.sh"
+ (("/bin/sh") (which "sh"))))))))
+ (home-page "https://www.gnu.org/software/ed/")
+ (synopsis "Line-oriented text editor")
+ (description
+ "Ed is a line-oriented text editor: rather than offering an overview of
+a document, ed performs editing one line at a time. It can be executed both
+interactively and via shell scripts. Its method of command input allows
+complex tasks to be performed in an automated way. GNU ed offers several
+extensions over the standard utility.")
+ (license license:gpl3+)))
+
(define-public vis
(package
(name "vis")