aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-07-06 00:29:00 -0400
committerLeo Famulari <leo@famulari.name>2023-07-06 00:31:41 -0400
commitdb803cce11f15ce0df41a910b4721c706e8b4d8f (patch)
treebdbd571afa7fa3cd26a83ee4c80f4e8bb98298a1 /gnu/packages/text-editors.scm
parent3eb27717847542de9aa31cbed471a38db3046455 (diff)
downloadguix-db803cce11f15ce0df41a910b4721c706e8b4d8f.tar
guix-db803cce11f15ce0df41a910b4721c706e8b4d8f.tar.gz
gnu: l3afpad: Update to 0.8.18.1.11-0.16f2222.
* gnu/packages/text-editors.scm (l3afpad): Update to 0.8.18.1.11-0.16f2222. [arguments]: Install the README and the man page.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 1781e75af2..f70a4302fd 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -433,7 +433,7 @@ compiled, requires few libraries, and starts up quickly.")
(license license:gpl2+)))
(define-public l3afpad
- (let ((commit "5235c9e13bbf0d31a902c6776918c2d7cdbb61ff")
+ (let ((commit "16f22222116b78b7f6a6fd83289937cdaabed624")
(revision "0"))
(package
(name "l3afpad")
@@ -446,8 +446,20 @@ compiled, requires few libraries, and starts up quickly.")
(commit commit)))
(sha256
(base32
- "1alyghm2wpakzdfag0g4g8gb1h9l4wdg7mnhq8bk0iq5ryqia16a"))))
+ "0q55351lvvlw9bi35l49mxa43g4fv110pwprzkk9m5li77vb0bcp"))))
(build-system glib-or-gtk-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" #$name "-"
+ #$(package-version this-package)))
+ (man (string-append out "/share/man/man1")))
+ (install-file "l3afpad.1" man)
+ (install-file "README" doc)))))))
(native-inputs
(list intltool autoconf automake pkg-config))
(inputs