aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/text-editors.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
downloadguix-7df09ee0ab3e7962ef27859ce87e06a323059284.tar
guix-7df09ee0ab3e7962ef27859ce87e06a323059284.tar.gz
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm88
1 files changed, 35 insertions, 53 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index f9330008e7..e05a58c447 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -73,8 +74,8 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages hunspell)
- #:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
@@ -300,7 +301,7 @@ can load dynamic libraries.")
"1pmr598xxxm9j9dl93kq4dv36zyw0q2dh6d7x07hf134y9hhlnj9"))))
(build-system gnu-build-system)
(inputs (list ncurses))
- (home-page "http://joe-editor.sourceforge.net/")
+ (home-page "https://joe-editor.sourceforge.net/")
(synopsis "Console screen editor")
(description
"JOE is a powerful console screen editor with a \"mode-less\" user
@@ -1256,57 +1257,6 @@ similar to vi/ex.")
FreeDOS as a functional clone of the old MS-DOS program edlin.")
(license license:gpl2+)))
-(define-public tree-sitter
- (package
- (name "tree-sitter")
- (version "0.20.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tree-sitter/tree-sitter")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z20518snyg0zp75qgs5bxmzjqws4dd19vnp6sya494za3qp5b6d"))
- (modules '((guix build utils)))
- (snippet '(begin
- ;; Remove bundled ICU parts
- (delete-file-recursively "lib/src/unicode")
- #t))))
- (build-system gnu-build-system)
- (inputs (list icu4c))
- (arguments
- (list #:phases
- '(modify-phases %standard-phases
- (delete 'configure))
- #:tests? #f ; there are no tests for the runtime library
- #:make-flags
- #~(list (string-append "PREFIX="
- #$output)
- (string-append "CC="
- #$(cc-for-target)))))
- (home-page "https://tree-sitter.github.io/tree-sitter/")
- (synopsis "Incremental parsing system for programming tools")
- (description
- "Tree-sitter is a parser generator tool and an incremental parsing
-library. It can build a concrete syntax tree for a source file and efficiently
-update the syntax tree as the source file is edited.
-
-Tree-sitter aims to be:
-
-@itemize
-@item General enough to parse any programming language
-@item Fast enough to parse on every keystroke in a text editor
-@item Robust enough to provide useful results even in the presence of syntax errors
-@item Dependency-free so that the runtime library (which is written in pure C)
-can be embedded in any application
-@end itemize
-
-This package includes the @code{libtree-sitter} runtime library.
-")
- (license license:expat)))
-
(define-public mle
(package
(name "mle")
@@ -1431,3 +1381,35 @@ for configuration and extensibility. It provides emulation modes for the
key bindings of many editors (including Emacs and WordStar), and has syntax
highlighting for dozens of languages. Jed is very small and fast.")
(license license:gpl2+)))
+
+(define-public xnedit
+ (package
+ (name "xnedit")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xnedit/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "linux" make-flags))))))
+ (inputs (list motif pcre))
+ (native-inputs (list pkg-config))
+ (home-page "https://sourceforge.net/projects/xnedit/")
+ (synopsis "Fast and classic X11 text editor")
+ (description
+ "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+ (license license:gpl2+)))