aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:43 +0200
commit64a5cafb550d80454cfee3abb5f5130c00ab2a17 (patch)
treed4af235f5dd1e34630913d50966a7576ab345477 /gnu/packages/text-editors.scm
parente02a49e11d653485fac4b6195265484c0e47d283 (diff)
downloadguix-64a5cafb550d80454cfee3abb5f5130c00ab2a17.tar
guix-64a5cafb550d80454cfee3abb5f5130c00ab2a17.tar.gz
gnu: ne: Cross-compile.
* gnu/packages/text-editors.scm (ne)[arguments]: Use CC-FOR-TARGET and don't strip binaries.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index f278b0902c..26abe60808 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -1136,7 +1136,8 @@ card. It offers:
(arguments
`(#:tests? #f
#:make-flags
- (list "CC=gcc"
+ (list "STRIP=true" ; don't
+ (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "LDFLAGS=-L" (assoc-ref %build-inputs "ncurses")
"/lib"))