aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/texlive.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-08-08 10:31:16 +0200
committerAndreas Enge <andreas@enge.fr>2023-08-17 16:19:05 +0200
commitce63901128faeaa3a7bf920a56775639a9d5f8f1 (patch)
treeafbc3670544a21d2dd5a1aedbb5b4625bb00aa8f /gnu/packages/texlive.scm
parent6274dcbdbd2c1f8c539d7dbc8675e713d14d1af8 (diff)
downloadguix-ce63901128faeaa3a7bf920a56775639a9d5f8f1.tar
guix-ce63901128faeaa3a7bf920a56775639a9d5f8f1.tar.gz
gnu: texlive: Improve the monolithic packages for non-x86_64 architectures.
* gnu/packages/texlive.scm (texlivebin)[arguments]: Enable tests also on aarch64 and powerpc64le. Remove 'disable-failing-test and 'skip-faulty-test phases. (texlivetexmf)[arguments]: Define a missing variable.
Diffstat (limited to 'gnu/packages/texlive.scm')
-rw-r--r--gnu/packages/texlive.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index b6bc3f30f7..0c5bc604a9 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -191,9 +191,7 @@
;; XXX FIXME fix luajit properly on these architectures.
#:tests? ,(let ((s (or (%current-target-system)
(%current-system))))
- (not (or (string-prefix? "aarch64" s)
- (string-prefix? "mips64" s)
- (string-prefix? "powerpc64le" s))))
+ (not (string-prefix? "mips64" s)))
#:phases
(modify-phases %standard-phases
@@ -216,30 +214,12 @@
(substitute* "texk/texlive/linked_scripts/epstopdf/epstopdf.pl"
(("\"gs\"")
(string-append "\"" (assoc-ref inputs "ghostscript") "/bin/gs\"")))))
- (add-after 'unpack 'disable-failing-test
- (lambda _
- ;; FIXME: This test fails on 32-bit architectures since Glibc 2.28:
- ;; <https://bugzilla.redhat.com/show_bug.cgi?id=1631847>.
- (substitute* "texk/web2c/omegafonts/check.test"
- (("^\\./omfonts -ofm2opl \\$srcdir/tests/check tests/xcheck \\|\\| exit 1")
- "./omfonts -ofm2opl $srcdir/tests/check tests/xcheck || exit 77"))))
(add-after 'unpack 'unpack-texlive-extra
(lambda* (#:key inputs #:allow-other-keys)
(mkdir "texlive-extra")
(with-directory-excursion "texlive-extra"
(apply (assoc-ref %standard-phases 'unpack)
(list #:source (assoc-ref inputs "texlive-extra-src"))))))
- ,@(if (target-arm32?)
- `((add-after 'unpack 'skip-faulty-test
- (lambda _
- ;; Skip this faulty test on armhf-linux:
- ;; https://issues.guix.gnu.org/54055
- (substitute* '("texk/mendexk/tests/mendex.test"
- "texk/upmendex/tests/upmendex.test")
- (("^TEXMFCNF=" all)
- (string-append "exit 77 # skip\n" all))))))
- '())
-
(add-after 'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
(let* ((out (assoc-ref outputs "out"))
@@ -345,6 +325,7 @@ This package contains the binaries.")
(share (string-append out "/share"))
(texmfroot (string-append share "/texmf-dist/web2c"))
(texmfcnf (string-append texmfroot "/texmf.cnf"))
+ (fmtutilcnf (string-append texmfroot "/fmtutil.cnf"))
(texlive-bin (assoc-ref inputs "texlive-bin"))
(texbin (string-append texlive-bin "/bin"))
(tlpkg (string-append texlive-bin "/share/tlpkg")))