aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/texlive.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-17 00:57:02 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-17 00:57:02 +0100
commitc0589f7591e40517b0cc5387cbc13e29567cdbd5 (patch)
tree3f04fb5fb3b3b916c8bb0f89d694a8203afb9ded /gnu/packages/texlive.scm
parent5ee12e217c8ac59dc4515ef12416242d112d938c (diff)
downloadguix-c0589f7591e40517b0cc5387cbc13e29567cdbd5.tar
guix-c0589f7591e40517b0cc5387cbc13e29567cdbd5.tar.gz
gnu: Add X.org as input to Texlive.
* gnu/packages/texlive.scm (texlive): Add x.org inputs.
Diffstat (limited to 'gnu/packages/texlive.scm')
-rw-r--r--gnu/packages/texlive.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index 8ea78de873..090d342054 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages tcsh)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages zip))
(define texlive-extra-src
@@ -66,6 +67,8 @@
("icu4c" ,icu4c)
("ghostscript" ,ghostscript)
("libpng" ,libpng)
+ ("libxaw" ,libxaw)
+ ("libxt" ,libxt)
("perl" ,perl)
("poppler" ,poppler)
("pkg-config" ,pkg-config)
@@ -88,7 +91,6 @@
,(string-append "--datarootdir=" (assoc-ref %outputs "data"))
,(string-append "--infodir=" (assoc-ref %outputs "out") "/share/info")
,(string-append "--mandir=" (assoc-ref %outputs "out") "/share/man")
- "--without-x" ; FIXME: Drop as soon as X is available.
"--with-system-freetype2"
;; "--with-system-gd"
;; "--with-system-graphite"