aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/texinfo.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index f9c40b3450..13fb92d14a 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -69,13 +69,11 @@
"env "))
#t)))
%standard-phases)))
- (inputs `(("ncurses" ,ncurses)
- ("perl" ,perl)))
+ (inputs (list ncurses perl))
;; When cross-compiling, texinfo will build some of its own binaries with
;; the native compiler. This means ncurses is needed both in both inputs
;; and native-inputs.
- (native-inputs `(("perl" ,perl)
- ("ncurses" ,ncurses)))
+ (native-inputs (list perl ncurses))
(native-search-paths
;; This is the variable used by the standalone Info reader.
@@ -118,11 +116,10 @@ is on expressing the content semantically, avoiding physical markup commands.")
(sha256
(base32
"1rf9ckpqwixj65bw469i634897xwlgkm5i9g2hv3avl6mv7b0a3d"))))
- (inputs `(("ncurses" ,ncurses)
- ("xz" ,xz)))
+ (inputs (list ncurses xz))
(native-inputs
- `(("automake" ,automake)
- ,@(package-native-inputs texinfo)))
+ (modify-inputs (package-native-inputs texinfo)
+ (prepend automake)))
(arguments
(substitute-keyword-arguments (package-arguments texinfo)
((#:phases phases)
@@ -207,7 +204,7 @@ is on expressing the content semantically, avoiding physical markup commands.")
(utime "texi2html.pl" 0 0 0 0)
#t))))
(build-system gnu-build-system)
- (inputs `(("perl" ,perl)))
+ (inputs (list perl))
(arguments
;; Tests fail because of warnings on stderr from Perl 5.22. Adjusting
;; texi2html.pl to avoid the warnings seems non-trivial, so we simply
@@ -273,8 +270,7 @@ Texi2HTML.")
(string-append "\"" (which "clear") "\"")))
#t)))))
(inputs
- `(("ncurses" ,ncurses)
- ("readline" ,readline)))
+ (list ncurses readline))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)