aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:15:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:33 +0200
commitf4ce4a8e402e4bfe8fcd0af2cf63955d5e8ca2e4 (patch)
tree0a5e97d31746e9dc3ac9d29fe25e4541b921ea25 /gnu/packages/tex.scm
parentc95939196a4ed2a5e7437a376d4c73778632cc95 (diff)
downloadguix-f4ce4a8e402e4bfe8fcd0af2cf63955d5e8ca2e4.tar
guix-f4ce4a8e402e4bfe8fcd0af2cf63955d5e8ca2e4.tar.gz
gnu: Add texlive-pst-eucl.
* gnu/packages/tex.scm (texlive-pst-eucl): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 51e2e4fd10..ac3695e512 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32851,6 +32851,28 @@ fly to encapsulated PostScript (EPS) image files, which can then be read into
a document in the usual way.")
(license license:lppl)))
+(define-public texlive-pst-eucl
+ (package
+ (name "texlive-pst-eucl")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-eucl/" "dvips/pst-eucl/"
+ "tex/generic/pst-eucl/"
+ "tex/latex/pst-eucl/")
+ (base32
+ "070f7chfvj65mhhdnghblhlq0ywvy76bw17dcb8519ixra6p4f4d")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-eucl")
+ (synopsis "Euclidian geometry with PSTricks")
+ (description
+ "The package allows the drawing of Euclidean geometric figures using TeX
+PSTricks macros for specifying mathematical constraints. It is thus possible
+to build point using common transformations or intersections. The use of
+coordinates is limited to points which controlled the figure.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")