aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:32 +0200
commitf122aead0d612f74b186482d2ce260e94f194f20 (patch)
tree1e802ab69d8699b3be4e6df7e1e4b74096948316 /gnu/packages/tex.scm
parent84cb690281a5024decde5268ccb6d246c2a6fcf4 (diff)
downloadguix-f122aead0d612f74b186482d2ce260e94f194f20.tar
guix-f122aead0d612f74b186482d2ce260e94f194f20.tar.gz
gnu: Add texlive-xassoccnt.
* gnu/packages/tex.scm (texlive-xassoccnt): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d7ce4200cb..4a5cd97d5f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99997,6 +99997,32 @@ LaTeX commands, which allow easy and robust definition of macros with many
optional arguments, using a clear and simple @code{xkeyval}-style syntax.")
(license license:lppl)))
+(define-public texlive-xassoccnt
+ (package
+ (name "texlive-xassoccnt")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xassoccnt/"
+ "tex/latex/xassoccnt/")
+ (base32
+ "0b38fjfi9ydm0snkdwmgzm2qrmh32dzl3k8ypj06fwaan7n3341n")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xassoccnt")
+ (synopsis "Associated counters stepping simultaneously")
+ (description
+ "This package provides a way of associating counters to an existing driver
+counter so that incrementing the driver counter will increase its associated
+counters as well. This package can be regarded as a supplement to the
+@code{totcount} package, but it can be used without it, too.
+
+@code{xassoccnt} is a successor and a complete rewrite of the @code{assoccnt}
+package. However, some features of @code{assoccnt} are not (yet) contained in
+@code{xassoccnt} so that the older package cannot yet be regarded as
+obsolete.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar