aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorThomas Albers <thomas@thomaslabs.org>2023-03-08 19:49:08 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-21 19:13:33 +0100
commite4319d4ca61c5281a58d863b0481e59bc6da82e0 (patch)
tree9d5b8370d5764bc8e41b215268314ae8c81a2814 /gnu/packages/tex.scm
parent4fbae445f7e3f95d90c11dd505383f276ad60fae (diff)
downloadguix-e4319d4ca61c5281a58d863b0481e59bc6da82e0.tar
guix-e4319d4ca61c5281a58d863b0481e59bc6da82e0.tar.gz
gnu: Add dvisvgm.
* gnu/packages/tex.scm (dvisvgm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0c4e545edf..1ce5b2ada8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2022 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +64,8 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages lisp)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
@@ -8341,6 +8344,47 @@ PDF documents.")
develop documents with LaTeX, in a single application.")
(license license:gpl2+)))
+(define-public dvisvgm
+ (package
+ (name "dvisvgm")
+ (version "3.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mgieseki/dvisvgm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11r401yqbw61n1mwsfk5qmwx2c92djwpl0q756qkds5kh25l9ci8"))))
+ (native-inputs (list pkg-config
+ autoconf
+ autoconf-archive
+ automake
+ python-wrapper
+ libtool))
+ (inputs (list texlive-libkpathsea
+ freetype
+ fontforge
+ clipper
+ ghostscript
+ xxhash
+ google-brotli
+ woff2
+ zlib))
+ (build-system gnu-build-system)
+ (synopsis "Command-line utility for generating SVG from DVI, EPS and PDF
+files")
+ (description
+ "Dvisvgm converts TeX DVI, EPS and PDF files into an
+SVG (Scalable Vector Graphics) image. It provides full font support including
+virtual fonts, font maps and sub-fonts. The embedded SVG fonts can optionally
+be replaced with graphics paths for applications that do not support SVG
+fonts. Dvisvgm supports also colors, emTeX, tpic, papersize, PDF mapfile
+and PostScript specials. A working TeX installation is needed.")
+ (home-page "https://dvisvgm.de/")
+ (license license:gpl3+)))
+
(define-public teximpatient
;; The homepage seems to be distributing this version which is currently the
;; most recent commit