aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 23:34:59 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:24 +0200
commite2515315a2e12cef439b8c0a00bef52ff211dedd (patch)
tree6f78dcb27937977b462bc9f73c11ea58a17dcfcd /gnu/packages/tex.scm
parenta19631329b949d8db9c86b70ea0ce0f1adba0124 (diff)
downloadguix-e2515315a2e12cef439b8c0a00bef52ff211dedd.tar
guix-e2515315a2e12cef439b8c0a00bef52ff211dedd.tar.gz
gnu: Add texlive-pmx-bin.
* gnu/packages/tex.scm (texlive-pmx-bin): New variable. (texlive-pmx)[propagated-inputs]: Add TEXLIVE-PMX-BIN. Change-Id: Ie392c5735f495d724e44ab1e3a88e19be00edaf5
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bd32f79bc4..caba8a54e7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25655,6 +25655,7 @@ is recommended.")
"1p9js9izv50vg7qqqmyg5jz4am4phhscqdfnn4nszlyfv3zkg7p3")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-pmx-bin))
(home-page "https://ctan.org/pkg/pmx")
(synopsis "Preprocessor for MusiXTeX")
(description
@@ -25667,6 +25668,52 @@ your score. @command{scor2prt} is an auxiliary program that makes parts from
a score.")
(license license:gpl2)))
+(define-public texlive-pmx-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-pmx-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '("pmx"))
+ (delete-other-directories "texk" '())))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-pmx" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "utils/pmx"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "utils/pmx"
+ (invoke "make" "install"))))))))
+ (native-inputs '())
+ (inputs '())
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-pmx))
+ (synopsis "Binaries for @code{texlive-pmx}")
+ (description
+ "This package provides the binaries for @code{texlive-pmx}.")
+ (license (package-license texlive-pmx))))
+
(define-public texlive-pmxchords
(package
(name "texlive-pmxchords")