aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:22:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:38 +0200
commitd9a875badd6ce198d324082e1d6f950f93e5c407 (patch)
tree1c6d6f8b8ff3a4eeaf235b7e5ad5223a25d72cd3 /gnu/packages/tex.scm
parent3025e4e2cae317606c5ee458f86d85b40c1fe31a (diff)
downloadguix-d9a875badd6ce198d324082e1d6f950f93e5c407.tar
guix-d9a875badd6ce198d324082e1d6f950f93e5c407.tar.gz
gnu: Add texlive-pst-knot.
* gnu/packages/tex.scm (texlive-pst-knot): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index da2720b9a3..f6f83dccb6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33299,6 +33299,26 @@ paths or Bezier curves, using the Bezier clipping algorithm.")
"jTree uses PSTricks to enable linguists to typeset complex trees.")
(license license:lppl1.3+)))
+(define-public texlive-pst-knot
+ (package
+ (name "texlive-pst-knot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-knot/" "dvips/pst-knot/"
+ "tex/generic/pst-knot/"
+ "tex/latex/pst-knot/")
+ (base32
+ "1b69m4qwd37vd3x734r4hp4wzsirsp6k5m87yqmxlhlkrf0wmrwc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-knot")
+ (synopsis "PSTricks package for displaying knots")
+ (description
+ "The package can produce a fair range of knot shapes, with all the
+standard graphics controls one expects.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")