aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:30:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:24 +0200
commit7d1ba37a6973d650939698c3b805735938be809f (patch)
treeff791a6368b275ae3bc37cb7a4e6c283352bfdd6 /gnu/packages/tex.scm
parentfc692a2d3298dc7c11e2e192073ebc5edd074321 (diff)
downloadguix-7d1ba37a6973d650939698c3b805735938be809f.tar
guix-7d1ba37a6973d650939698c3b805735938be809f.tar.gz
gnu: Add texlive-classicthesis.
* gnu/packages/tex.scm (texlive-classicthesis): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2dda32beec..67bb672b29 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9224,6 +9224,27 @@ small capitals, and old-style numerals) and variant forms for particular
languages.")
(license (list license:silofl1.1 license:gpl2+))))
+(define-public texlive-classicthesis
+ (package
+ (name "texlive-classicthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/classicthesis/"
+ "tex/latex/classicthesis/")
+ (base32
+ "0djx7vcrc1ksbgppdbwy31z5qd95flgsgqk6gpzpi3a5rc7h54nz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/classicthesis")
+ (synopsis "Classically styled thesis package")
+ (description
+ "This package provides an elegant layout designed in homage to
+Bringhurst's @emph{The Elements of Typographic Style}. It makes use of
+a range of techniques to get the best results achievable using TeX. Included
+in the bundle are templates to make thesis writing easier.")
+ (license license:gpl2+)))
+
(define-public texlive-clearsans
(package
(name "texlive-clearsans")