aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:16:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:34 +0200
commit3c5ad91b1f58e1fdd2edc2e4c11ba543bc936fdf (patch)
tree7aeaca466f8e11e9f21bdae6eac95560df201fe9 /gnu/packages/tex.scm
parent300b438e66e7b35c307251461652372f06b9f823 (diff)
downloadguix-3c5ad91b1f58e1fdd2edc2e4c11ba543bc936fdf.tar
guix-3c5ad91b1f58e1fdd2edc2e4c11ba543bc936fdf.tar.gz
gnu: Add texlive-pst-flags.
* gnu/packages/tex.scm (texlive-pst-flags): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7da546dbd9..e2b3114e4a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32951,6 +32951,30 @@ functions; exp function; logarithm functions; Recip; Kings Law data; Gaussian;
and fourth order polynomials.")
(license license:lppl)))
+(define-public texlive-pst-flags
+ (package
+ (name "texlive-pst-flags")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pst-flags/"
+ "tex/latex/pst-flags/")
+ (base32
+ "13078q4mg1r8hg5zvywfasfz26phcr9dvsw4s05spc116b8fz9gn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-flags")
+ (synopsis "Draw flags of countries using PSTricks")
+ (description
+ "This package provides a number of macros for rendering flags of
+countries and their associated artefacts using PSTricks. Formatting of the
+resulting drawings is entirely controlled by TeX macros. A good working
+knowledge of LaTeX should be sufficient to design flags of sovereign countries
+and adapt them to create new designs. Features such as color or shape
+customisation and dynamic modifications are possible by cleverly adjusting the
+options supplied to the TeX macros.")
+ (license license:lppl1.3c)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")