aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 15:26:07 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:26 +0200
commit102a3a3a048aa6e01c6410ca073752eae7bdbbc5 (patch)
tree40cd2be42d52938274f93ede6ed6b60103fb8f33 /gnu/packages/tex.scm
parentf16db7fd1bd325375b7ea064166e4314ea6e8a61 (diff)
downloadguix-102a3a3a048aa6e01c6410ca073752eae7bdbbc5.tar
guix-102a3a3a048aa6e01c6410ca073752eae7bdbbc5.tar.gz
gnu: Add texlive-cjkutils-bin.
* gnu/packages/tex.scm (texlive-cjkutils-bin): New variable. (texlive-cjkutils)[propagated-inputs]: Add TEXLIVE-CJKUTILS-BIN. Change-Id: I0790442c9295a00fdb7024d844a75dcac2f9ad3a
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f97d838e22..b4c519f4b6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9446,6 +9446,7 @@ adjust locations and kerning of CJK punctuation marks.")
"0by2g05xv5dndnd78jz9y73fyswqhfvcbzcw8rzhvpvd6inrcdq8")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-cjkutils-bin))
(home-page "https://ctan.org/pkg/cjk")
(synopsis "CJK language support")
(description
@@ -9458,6 +9459,52 @@ the above --- Cyrillic, Greek, Latin-based scripts, Russian and Vietnamese are
supported.")
(license license:gpl2)))
+(define-public texlive-cjkutils-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-cjkutils-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs/" '())
+ (delete-other-directories "utils/" '())
+ (delete-other-directories "texk/" '("cjkutils"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons "--enable-cjkutils-x" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/cjkutils"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/cjkutils"
+ (invoke "make" "install"))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list texlive-libkpathsea))
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-cjkutils))
+ (synopsis "Binaries for @code{texlive-cjkutils}")
+ (description
+ "This package provides the binaries for @code{texlive-cjkutils}.")
+ (license (package-license texlive-cjkutils))))
+
(define-public texlive-clara
(package
(name "texlive-clara")