aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 22:07:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 22:07:44 +0100
commitd792bb30b610e0528c4f92a946a0ee3671fea368 (patch)
treeba0cbbfc3acf2ae87f789b271a3fa2c8a4ab3a41 /gnu/packages/terminals.scm
parentb13e353147eaf4513fe74babc5bcd21cef4c669f (diff)
downloadguix-d792bb30b610e0528c4f92a946a0ee3671fea368.tar
guix-d792bb30b610e0528c4f92a946a0ee3671fea368.tar.gz
gnu: go-github-com-junegunn-fzf: Update to 0.54.3.
* gnu/packages/terminals.scm (go-github-com-junegunn-fzf): Update to 0.54.3. [inputs]: Remove go-github-com-mattn-go-runewidth, go-github-com-gdamore-tcell, go-github-com-saracen-walker, go-golang-org-x-sync, and go-golang-org-x-crypto; add go-github-com-charlievieth-fastwalk, go-github-com-gdamore-tcell-v2, and go-golang-org-x-sys. Change-Id: I19dee1bed268c5cb33a3f4990fcdaf8046dd6bc6
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 1134c5700c..2127a0279c 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1019,30 +1019,28 @@ programmer to write text-based user interfaces.")
(define-public go-github-com-junegunn-fzf
(package
(name "go-github-com-junegunn-fzf")
- (version "0.41.0")
+ (version "0.54.3")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/junegunn/fzf")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1l9nsvziip3azyvg8wi4g3x606fh6w9vpfcbcgjdzdnp2ywqciim"))))
+ "0mdj3z7w2igkvy8r304k9rcr2l6xm459ifshdm55iy6mazd8cmci"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/junegunn/fzf"))
(inputs
- (list go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-shellwords
+ (list go-github-com-charlievieth-fastwalk
+ go-github-com-gdamore-tcell-v2
go-github-com-mattn-go-isatty
- go-github-com-gdamore-tcell
+ go-github-com-mattn-go-shellwords
go-github-com-rivo-uniseg
- go-github-com-saracen-walker
- go-golang-org-x-sync
- go-golang-org-x-term
- go-golang-org-x-crypto))
+ go-golang-org-x-sys
+ go-golang-org-x-term))
(home-page "https://github.com/junegunn/fzf")
(synopsis "Command-line fuzzy-finder")
(description "This package provides an interactive command-line filter