aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-11-16 19:07:09 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-04 23:08:21 +0100
commitf4b4875bc06d185577188b2539985d64195f0ff1 (patch)
treec032040d43a2f2cacfe80de0332d19e65fd05c6c /gnu/packages/telephony.scm
parenteaef825928bc4498b32808308b05d3f5ae69d6a3 (diff)
downloadguix-f4b4875bc06d185577188b2539985d64195f0ff1.tar
guix-f4b4875bc06d185577188b2539985d64195f0ff1.tar.gz
gnu: Add xgoldmon.
* gnu/packages/telephony.scm (xgoldmon): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 2f508f4bdd..302b351fbb 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -979,3 +979,54 @@ TURN (Traversal Using Relays around NAT) server protocols.")
@end itemize")
(home-page "https://osmocom.org/projects/libosmocore/wiki/Libosmocore")
(license license:gpl2+)))
+
+(define-public xgoldmon
+ ;; There are no releases nor tags.
+ (let ((revision "1")
+ (commit "f2d5372acee4e492f31f6ba8b850cfb48fbbe478"))
+ (package
+ (name "xgoldmon")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/2b-as/xgoldmon")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dvgagqsbwq1sd5qjzk0hd9rxnv2vnmhazvv5mz4pj7v467amgdz"))))
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (let ((bin (string-append #$output "/bin"))
+ (doc (string-append #$output "/share/doc")))
+ (install-file "xgoldmon" bin)
+ (install-file "README" doc)
+ (install-file
+ "screenshot-mtsms-while-in-a-call.png" doc)))))))
+ (inputs (list libosmocore lksctp-tools talloc))
+ (native-inputs (list pkg-config))
+ (build-system gnu-build-system)
+ (synopsis "Displays cellular network protocol traces in Wireshark")
+ (description
+ "xgoldmon is an utility that converts the USB logging mode
+messages that various Intel/Infineon XGold modems send to the USB port to
+gsmtap. It then then sends them to a given IP address to enable users
+to view cellular network protocol traces in Wireshark.
+
+It supports the following smartphones:
+@itemize
+@item Samsung Galaxy S4, GT-I9500 variant
+@item Samsung Galaxy SIII, GT-I9300 variant
+@item Samsung Galaxy Nexus, GT-I9250 variant
+@item Samsung Galaxy SII, GT-I9100 variant
+@item Samsung Galaxy Note II, GT-N7100 variant
+@end itemize")
+ (home-page "https://github.com/2b-as/xgoldmon")
+ (license license:gpl2+))))