aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:51:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:40 +0200
commit4442aa8780dfaf5d40dee63ffd0d61222ab73eb0 (patch)
tree34df8881812e734a6225084ad95a4911e08c2033 /gnu/packages/syndication.scm
parentbd90c7d462fcf426d77f4aceb3f64634b86e0596 (diff)
downloadguix-4442aa8780dfaf5d40dee63ffd0d61222ab73eb0.tar
guix-4442aa8780dfaf5d40dee63ffd0d61222ab73eb0.tar.gz
gnu: newsboat: Prepare for cross-building.
* gnu/packages/syndication.scm (newsboat)[arguments]: Add a phase to use the correct compiler when cross-compiling. Change-Id: I1a560af41471cb8899322813f8a18c15ac0e5924
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 5a9d5ed480..8f2882cff9 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -287,6 +287,14 @@ cards.")
(("^doc:.*") "doc:\n")
(("install-podboat install-docs") "install-podboat")))))
'())
+ (add-after 'unpack 'pre-build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CXX" ,(cxx-for-target))
+ (setenv "CXX_FOR_BUILD" (which "g++"))
+ (substitute* "config.sh"
+ (("if curl-config")
+ (string-append
+ "if " (search-input-file inputs "/bin/curl-config"))))))
(add-after 'configure 'dont-vendor-self
(lambda* (#:key vendor-dir #:allow-other-keys)
;; Don't keep the whole tarball in the vendor directory