aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-17 14:46:48 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:18 -0400
commit2c54d3f48934c7515bb85b0ef575aec4ce64ad25 (patch)
treec906c17f13d57a1f768220e8dae1b43208718270 /gnu/packages/syndication.scm
parent592c6523b7ea09b3130ccfd68c6dbe5802275549 (diff)
downloadguix-2c54d3f48934c7515bb85b0ef575aec4ce64ad25.tar
guix-2c54d3f48934c7515bb85b0ef575aec4ce64ad25.tar.gz
gnu: gfeeds: Update to 2.2.0.
* gnu/packages/syndication.scm (gfeeds): Update to 2.2.0. [phases]: Fix skip-icon-cache phase. Use search-input-file in wrap-gfeeds.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index e11e6ae960..cc6ead859e 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
+;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -534,7 +535,7 @@ parser. It is \"not fit for use at this point\", but gfeeds uses it anyway.")
(define-public gfeeds
(package
(name "gfeeds")
- (version "1.0.3")
+ (version "2.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -543,7 +544,7 @@ parser. It is \"not fit for use at this point\", but gfeeds uses it anyway.")
(file-name (git-file-name name version))
(sha256
(base32
- "1lkvhff7pl1y4brqsix6sar5yl8flyhfp3w96fx0klhk3586bvhg"))))
+ "0p2hyjif9yhpc6r3ig7fdxpb2q8s9g42mz38svsc38gq7hb13b2w"))))
(build-system meson-build-system)
(arguments
(list
@@ -555,12 +556,12 @@ parser. It is \"not fit for use at this point\", but gfeeds uses it anyway.")
(("mpv") (search-input-file inputs "/bin/mpv")))))
(add-after 'unpack 'skip-icon-cache
(lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'install 'wrap-gfeeds
(lambda* (#:key outputs #:allow-other-keys)
- (wrap-program (string-append
- (assoc-ref outputs "out") "/bin/gfeeds")
+ (wrap-program (search-input-file outputs "/bin/gfeeds")
`("PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
`("XDG_DATA_DIRS" ":" prefix (,(getenv "XDG_DATA_DIRS")))))))))