aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sugar.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-13 16:11:14 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-13 16:11:14 +0100
commit622df12ef389c9e91f68ae10c54c043f34828c83 (patch)
tree888542636c0717727d52a4cd56d42338601e661a /gnu/packages/sugar.scm
parent952c691b51f8f5d56df69686c2785414709c7949 (diff)
parent8a0910e042ad1670435613e06458a6fb2c4131c4 (diff)
downloadguix-622df12ef389c9e91f68ae10c54c043f34828c83.tar
guix-622df12ef389c9e91f68ae10c54c043f34828c83.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/sugar.scm')
-rw-r--r--gnu/packages/sugar.scm79
1 files changed, 37 insertions, 42 deletions
diff --git a/gnu/packages/sugar.scm b/gnu/packages/sugar.scm
index 4a0de1b55a..fe14e55bb4 100644
--- a/gnu/packages/sugar.scm
+++ b/gnu/packages/sugar.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,7 +53,7 @@
(define-public sugar
(package
(name "sugar")
- (version "0.120")
+ (version "0.121")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -62,7 +62,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0imhaj49n7ain33kmrqk19rzlfr50m84fbc011vgg1010ddp3vdw"))))
+ "1s31sz1j7x82vynd233k7jqqp881bpz7486r78wfz2i84f2n4n06"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
@@ -79,7 +79,10 @@
(lambda _
(substitute* "autogen.sh"
(("^\"\\$srcdir/configure" m)
- (string-append "#" m)))))
+ (string-append "#" m)))
+ ;; This .po file does not exist
+ (substitute* "po/LINGUAS"
+ (("^ig") ""))))
(add-after 'unpack 'fix-references
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "bin/sugar.in"
@@ -106,12 +109,6 @@
(dirname
(search-input-file inputs
"/share/mobile-broadband-provider-info/serviceproviders.xml"))))
- ;; XXX: spawn_command_line_sync is not used correctly here, so
- ;; we need to patch invocations.
- (substitute* '("extensions/cpsection/aboutcomputer/model.py"
- "src/jarabe/model/brightness.py")
- (("spawn_command_line_sync\\(cmd\\)")
- "spawn_command_line_sync(cmd, 0)"))
(substitute* "extensions/cpsection/aboutcomputer/model.py"
(("ethtool")
(search-input-file inputs "/sbin/ethtool")))
@@ -120,15 +117,11 @@
(string-append "'"
(search-input-file inputs "/bin/locale")
"'")))
- ;; XXX: The brightness component crashes, so we disable it here.
- (substitute* "src/jarabe/main.py"
- (("brightness.get_instance\\(\\)") ""))
- ;; TODO: these locations should be set to places that exist on
- ;; Guix System.
- #;
+ ;; This is a global location on Guix System. Ideally we would
+ ;; have a search path here.
(substitute* "extensions/cpsection/background/model.py"
(("\\('/usr', 'share', 'backgrounds'\\)")
- "('TODO')"))
+ "('/run', 'current-system', 'profile', 'share', 'backgrounds')"))
(substitute* "src/jarabe/view/viewhelp.py"
(("/usr/share/sugar/activities/")
"/run/current-system/profile/share/sugar/activities/"))))
@@ -161,7 +154,7 @@
gstreamer
gtk+
gtksourceview-3
- libsoup-minimal-2
+ libsoup-minimal
libwnck
libxklavier
network-manager
@@ -175,7 +168,7 @@
telepathy-salut ;for XMPP neighborhood
;; This is for the UPowerGlib namespace
upower
- webkitgtk-with-libsoup2))
+ webkitgtk-for-gtk3))
(native-inputs
(list autoconf automake
gettext-minimal
@@ -195,7 +188,7 @@ used every school day by children in more than forty countries.")
(define-public sugar-artwork
(package
(name "sugar-artwork")
- (version "0.120")
+ (version "0.121")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -204,7 +197,7 @@ used every school day by children in more than forty countries.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mjydyx7kbk429s3kswfb8x7g5smjwnai924avwxab1kjsjjksm9"))))
+ "00m3dmwswfy4whc2hs51lqckz1z1f2jnw94jhxgw40b17w00pzwj"))))
(build-system gnu-build-system)
(arguments
(list
@@ -219,7 +212,7 @@ used every school day by children in more than forty countries.")
(string-append "#" m))))))))
(inputs (list cairo gtk+))
(native-inputs
- (list autoconf automake
+ (list autoconf-2.71 automake
icon-naming-utils
libtool
pkg-config
@@ -236,7 +229,7 @@ activities and other Sugar components.")
(define-public sugar-datastore
(package
(name "sugar-datastore")
- (version "0.120")
+ (version "0.121")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -245,7 +238,7 @@ activities and other Sugar components.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wf33w6dm26i8a1zpb40339fj3l9vxjznagls9bc845nld318sqc"))))
+ "01mp0vyg9d6ig29p484prqlgqpa7a3pai8ki37dyk682gr0fhljb"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
@@ -293,7 +286,8 @@ activities and other Sugar components.")
python-pygobject
python-xapian-bindings))
(native-inputs
- (list autoconf automake
+ (list autoconf-2.71
+ automake
libtool
pkg-config))
(home-page "https://www.sugarlabs.org/")
@@ -305,7 +299,7 @@ and metadata, and the journal with querying and full text search.")
(define-public sugar-toolkit-gtk3
(package
(name "sugar-toolkit-gtk3")
- (version "0.120")
+ (version "0.121")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -314,7 +308,7 @@ and metadata, and the journal with querying and full text search.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wqanc38zplyiq1vxda4bj1n0xd78zqlwml6lzklsrbz923llykz"))))
+ "0x80jqx0z89jxfy2dvn4l35qbyvq3c2hg9jq4i0llq1qgkc4034b"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
@@ -368,9 +362,10 @@ and metadata, and the journal with querying and full text search.")
python-six
telepathy-glib
- webkitgtk-with-libsoup2))
+ webkitgtk-for-gtk3))
(native-inputs
- (list autoconf automake
+ (list autoconf-2.71
+ automake
gettext-minimal
glib
(list glib "bin")
@@ -386,11 +381,11 @@ the Sugar Toolkit.")
(define-public sugar-block-party-activity
- (let ((commit "a49e68ec00e647af712d8e284622722f2f78b6bf")
+ (let ((commit "26a58f14254d6ae38b7bfa3cb2fc63291eefcc97")
(revision "1"))
(package
(name "sugar-block-party-activity")
- (version (git-version "11" revision commit))
+ (version (git-version "12" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -399,7 +394,7 @@ the Sugar Toolkit.")
(file-name (git-file-name name version))
(sha256
(base32
- "0hy82c0gn1hr34arhnh9k6mx2789ki85fkgvga4sw6gwh31278pl"))))
+ "0zinqhwmvyvk1zvs28dr71p68vb6widn4v3zp35zlzj4ayyn5rvx"))))
(build-system python-build-system)
(arguments
(list
@@ -430,7 +425,7 @@ a Tetris-like game.")
(define-public sugar-browse-activity
(package
(name "sugar-browse-activity")
- (version "207")
+ (version "208")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -439,7 +434,7 @@ a Tetris-like game.")
(file-name (git-file-name name version))
(sha256
(base32
- "01p1gfdw9fhn92didc9sq23n6a3krs6findbbmicijz91kx8kfb2"))))
+ "1lxwkwz7bz8vd0jgsgvlwdm6gkrmzcmwlyqvp12j2jk5mpr4fp44"))))
(build-system python-build-system)
(arguments
(list
@@ -468,11 +463,11 @@ a Tetris-like game.")
gobject-introspection
gtk+
(librsvg-for-system)
- libsoup-minimal-2
+ libsoup-minimal
python-pygobject
sugar-toolkit-gtk3
telepathy-glib
- webkitgtk-with-libsoup2))
+ webkitgtk-for-gtk3))
(inputs
(list (list glib "bin")))
(native-inputs
@@ -528,8 +523,8 @@ to provide users with easy access to documentation and manuals.")
(license license:gpl3+))))
(define-public sugar-jukebox-activity
- (let ((commit "e11f40c94c1c6302d3e36ddf4dc8101732ffb9d9")
- (revision "1"))
+ (let ((commit "44ad1da717904a7c7d93a08985b94468a9b7ab7a")
+ (revision "2"))
(package
(name "sugar-jukebox-activity")
(version (git-version "36" revision commit))
@@ -541,7 +536,7 @@ to provide users with easy access to documentation and manuals.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gm1cj4vrwwdriyshd27w6vc0palwpg9pnnab5axinrnkzczyk1v"))))
+ "1c8g4h52jnwzk5vlkrkm8j0p5dbrjqd8hv3bdz5rp39w9in3skzk"))))
(build-system python-build-system)
(arguments
(list
@@ -640,7 +635,7 @@ looking for why an activity or Sugar is not working properly.")
(define-public sugar-maze-activity
(package
(name "sugar-maze-activity")
- (version "31")
+ (version "32")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -649,7 +644,7 @@ looking for why an activity or Sugar is not working properly.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ai2ws3mqkxi13chy0hidd1gxiv97862r9lg8qgxb7qkxqyh6afr"))))
+ "0506mwxy3agyxlilb5v3pn29pg45lzaxm8rhj9azm58irs3wdmnq"))))
(build-system python-build-system)
(arguments
(list
@@ -716,7 +711,7 @@ or you can also play with a friend!")
(list evince
gtk+
sugar-toolkit-gtk3
- webkitgtk-with-libsoup2))
+ webkitgtk-for-gtk3))
(inputs
(list gettext-minimal))
(home-page "https://help.sugarlabs.org/read.html")