aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/stb.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-18 18:07:32 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 23:25:56 +0100
commitd3b22d488babae461d03831a1bb5f776e53a13cb (patch)
treef28a8d327a2fa5531dc1d880870901f7ed276043 /gnu/packages/stb.scm
parent01a92a70c403ff0883733ec8ff0419f07d6b3ef4 (diff)
downloadguix-d3b22d488babae461d03831a1bb5f776e53a13cb.tar
guix-d3b22d488babae461d03831a1bb5f776e53a13cb.tar.gz
gnu: stb: Update snapshot.
* gnu/packages/stb.scm (stb): Update to commit 2c2908f50515dcd. (stb-image): Update to 2.22. (stb-image-write): Update to 1.13.
Diffstat (limited to 'gnu/packages/stb.scm')
-rw-r--r--gnu/packages/stb.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
index df31bd0f86..5444347644 100644
--- a/gnu/packages/stb.scm
+++ b/gnu/packages/stb.scm
@@ -26,8 +26,8 @@
(define stb
;; stb is a collection of libraries developed within the same repository.
;; When updating this, remember to change versions below as appropriate.
- (let ((commit "e6afb9cbae4064da8c3e69af3ff5c4629579c1d2")
- (revision "0"))
+ (let ((commit "2c2908f50515dcd939f24be261c3ccbcd277bb49")
+ (revision "1"))
(package
(name "stb")
(home-page "https://github.com/nothings/stb")
@@ -39,7 +39,7 @@
(commit commit)))
(sha256
(base32
- "079nsn9bnb8c0vfq26g5l53q6gzx19a5x9q2nb55mpcljxsgxnmf"))
+ "1z753rscqc4clp0rd57bw68i60kz694y1z52bwv6slzmkgds1cki"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -92,12 +92,12 @@ the C programming language.")
;; converted to macros as outlined in <https://bugs.gnu.org/32155>.
(define-public stb-image
(make-stb-header-package
- "stb-image" "2.19"
+ "stb-image" "2.22"
"stb-image is a small and self-contained library for image loading or
decoding from file or memory. A variety of formats are supported."))
(define-public stb-image-write
(make-stb-header-package
- "stb-image-write" "1.09"
+ "stb-image-write" "1.13"
"stb-image-write is a small library for writing image files to the
C@tie{}@code{stdio} interface."))