aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-07 12:11:24 -0400
committerLeo Famulari <leo@famulari.name>2017-06-07 12:11:55 -0400
commitc67d587f94173fd42d65097165afc5c512935646 (patch)
treeee2bac9d683d0dec98d611d5e590b06d9876cad3 /gnu/packages/ssh.scm
parent4f493cba06b97de756123b3855ea52dcf1ad3555 (diff)
parent4679dd6967c21e21c740cd88e17191b8e2aac5ee (diff)
downloadguix-c67d587f94173fd42d65097165afc5c512935646.tar
guix-c67d587f94173fd42d65097165afc5c512935646.tar.gz
Merge branch 'master' into core-updates
This merge commit includes a fix for CVE-2017-6512 in Perl 5.26.0.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index c96ed0a72b..d79663a2b5 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -58,15 +58,16 @@
(define-public libssh
(package
(name "libssh")
- (version "0.7.4")
+ (version "0.7.5")
(source (origin
(method url-fetch)
(uri (string-append
- "https://red.libssh.org/attachments/download/210/libssh-"
+ "https://red.libssh.org/attachments/download/218/libssh-"
version ".tar.xz"))
(sha256
(base32
- "03bcp9ksqp0s1pmwfmzhcknvkxay5k0mjzzxp3rjlifbng1vxq9r"))))
+ "15bh6dm9c50ndddzh3gqcgw7axp3ghrspjpkb1z3dr90vkanvs2l"))
+ (patches (search-patches "libssh-hostname-parser-bug.patch"))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments