aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-27 01:04:03 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-27 01:16:32 +0100
commit3f81ec18e4177f6bbc709b7319ec7d15147b3f1d (patch)
treea8050520c696cae676bee674d4d2f292ed4f8b00 /gnu/packages/ssh.scm
parent6bae14f61479f04a40fee44b1d1d89a33d9e93c0 (diff)
downloadguix-3f81ec18e4177f6bbc709b7319ec7d15147b3f1d.tar
guix-3f81ec18e4177f6bbc709b7319ec7d15147b3f1d.tar.gz
gnu: libssh: Fix compilation on GNU/Hurd.
* gnu/packages/ssh.scm (libssh)[source]: Add snippet.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index d4a73df335..886cb74070 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -140,7 +140,16 @@ file names.
"/libssh-" version ".tar.xz"))
(sha256
(base32
- "0zfr9fy4vg1bmz1k836hg9wi20mmaz2sgw61s6464iv1mda2qf87"))))
+ "0zfr9fy4vg1bmz1k836hg9wi20mmaz2sgw61s6464iv1mda2qf87"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; 'PATH_MAX' is undefined on GNU/Hurd; work around it.
+ #~(substitute* (find-files "examples" "\\.c$")
+ (("#include \"examples_common\\.h\"" all)
+ (string-append all "\n"
+ "#ifndef PATH_MAX\n"
+ "# define PATH_MAX 4096\n"
+ "#endif\n"))))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments