aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-27 17:10:55 +0200
committerMarius Bakke <marius@gnu.org>2022-08-27 17:10:55 +0200
commitad384816fe260be98bc53701d9d761197ef162fc (patch)
treeff06eb12983b7cbd972c3153404bb3952e2f28c0 /gnu/packages/sphinx.scm
parentd08411ffd0a36a6b67a238be69d32c9f74101389 (diff)
parentfb3d90b8f31c4b1e2e3d427544c6610f3fe1ce55 (diff)
downloadguix-ad384816fe260be98bc53701d9d761197ef162fc.tar
guix-ad384816fe260be98bc53701d9d761197ef162fc.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm26
1 files changed, 18 insertions, 8 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 065358a57f..dc3a90bbcb 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -62,14 +62,14 @@
(define-public python-sphinx
(package
(name "python-sphinx")
- (version "5.0.2")
+ (version "5.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Sphinx" version))
(sha256
(base32
- "1c67w48509k07pa1q3rp93lpchy8hp6h5iqrc3r20msnly79g3mi"))))
+ "12cdy3m5c09lpf2bbxzbhm5v5y9fk7jgm94qrzggpq86waj28cms"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -111,10 +111,6 @@
texlive-etoolbox
texlive-ltxcmds
texlive-hyperref
- ;; TODO: Remove texlive-stringenc and texlive-zapfding after
- ;; propagating them in texlive-hyperref in next rebuild cycle.
- texlive-stringenc
- texlive-zapfding
texlive-latex-base ;alltt, atbegshi, makeidx, textcomp
texlive-latex-cmap
texlive-fancyhdr
@@ -148,6 +144,18 @@ for Python projects or other documents consisting of multiple reStructuredText
sources.")
(license license:bsd-2)))
+;; Some packages do not support Sphinx 5 yet. Remove when unused.
+(define-public python-sphinx-4
+ (package
+ (inherit python-sphinx)
+ (version "4.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Sphinx" version))
+ (sha256
+ (base32
+ "1rp28jryxwy24y8vpacclqihbizyi6b1s6id86pibvm46ybcmy3v"))))))
+
(define-public python-sphinxcontrib-apidoc
(package
(name "python-sphinxcontrib-apidoc")
@@ -365,14 +373,16 @@ Blog, News or Announcements section to a Sphinx website.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest")))))))
- (propagated-inputs (list python-docutils python-sphinx))
+ (propagated-inputs (list python-docutils python-sphinx-4))
(native-inputs
(list python-pytest
python-pytest-regressions))
(home-page "https://github.com/executablebooks/sphinx-panels")
(synopsis "Sphinx extension for creating panels in a grid layout")
(description
- "This package provides a sphinx extension for creating panels in a grid layout.")
+ "This package provides a sphinx extension for creating panels in a
+grid layout. It is no longer maintained and users are encouraged to use
+@code{sphinx-design} instead.")
(license license:expat)))
(define-public python-sphinxcontrib-programoutput