aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/sphinx.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
downloadguix-4cf1acc7f3033b50b0bf19e02c9f522d522d338c.tar
guix-4cf1acc7f3033b50b0bf19e02c9f522d522d338c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 85902a8d96..b0484f9f6c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -42,6 +42,7 @@
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages check)
@@ -734,6 +735,54 @@ and several other projects.")
(description "This package provides a Matplotlib theme for Sphinx.")
(license license:bsd-3)))
+(define-public python-myst-parser
+ (package
+ (name "python-myst-parser")
+ (version "0.18.1")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/executablebooks/MyST-Parser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lcz9vvy8hbp6cjmbslrlxn3pinf98jykiq8nx5lw5y0lz0mj162"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; There are 3 test failures, seemingly due to expecting a slightly
+ ;; different output from Sphinx (see:
+ ;; https://github.com/executablebooks/MyST-Parser/issues/645).
+ (list #:test-flags #~(list "-k" (string-append
+ "not test_basic "
+ "and not test_gettext_html "
+ "and not test_fieldlist_extension"))))
+ (native-inputs
+ (list python-beautifulsoup4
+ python-docutils
+ python-flit-core
+ python-pytest
+ python-pytest-param-files
+ python-pytest-regressions
+ python-sphinx
+ python-sphinx-pytest))
+ (propagated-inputs
+ (list python-docutils
+ python-jinja2
+ python-linkify-it-py
+ python-markdown-it-py
+ python-linkify-it-py
+ python-mdit-py-plugins
+ python-pyyaml
+ python-sphinx
+ python-typing-extensions))
+ (home-page "https://myst-parser.readthedocs.io/en/latest/")
+ (synopsis "Sphinx and Docutils extension to parse MyST")
+ (description "This package provides a Sphinx and Docutils extension to parse
+MyST, a rich and extensible flavour of Markdown for authoring technical and
+scientific documentation.")
+ (license license:expat)))
+
(define-public python-sphinx-rtd-theme
(package
(name "python-sphinx-rtd-theme")
@@ -898,6 +947,26 @@ enabled web server.")
documenting acceptable argument types and return value types of functions.")
(license license:expat)))
+(define-public python-sphinx-pytest
+ (package
+ (name "python-sphinx-pytest")
+ (version "0.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx_pytest" version))
+ (sha256
+ (base32
+ "13d3psm5vyb8rdj0mhnpn5m09k8xdaszcxdpng52fpz9sw8pngk7"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (propagated-inputs (list python-pytest python-sphinx))
+ (home-page "https://github.com/chrisjsewell/sphinx-pytest")
+ (synopsis "Pytest fixtures for Sphinx extensions")
+ (description "This Pytest extension mainly provides some Pytest fixtures
+to simulate converting some source text to Docutils @acronym{AST, Abstract
+Syntax Tree} at different stages: before transforms, after transforms, etc.")
+ (license license:expat)))
+
(define-public python-nbsphinx
(package
(name "python-nbsphinx")