aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-03-29 12:58:42 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:41 +0200
commit2090a563bdc9f707dcb985d3011c0cfc40255717 (patch)
treef7a9e12ceca084fac444ce208af9adfe65c340e4 /gnu/packages/sphinx.scm
parentf9b04997f2a79b386ea06ae4b5211ccbd67c429f (diff)
downloadguix-2090a563bdc9f707dcb985d3011c0cfc40255717.tar
guix-2090a563bdc9f707dcb985d3011c0cfc40255717.tar.gz
gnu: sphinx: Use 'imagemagick/stable' variant.
As the store item does not retain a reference to imagemagick, it should be safe to use the 'imagemagick/stable' variant. * gnu/packages/sphinx.scm (python-sphinx) [arguments] Add #:disallowed-references to make sure no references to imagemagick are retained. [native-inputs]: Use 'imagemagick/stable' instead of 'imagemagick' and explain why that's a safe thing to do. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I04bdc94e012f3fcb30c4ec113a0ae2e9d9373210
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index e280c06f2b..bd84a4134d 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,7 +76,10 @@
"12cdy3m5c09lpf2bbxzbhm5v5y9fk7jgm94qrzggpq86waj28cms"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ `(;; Make sure it is safe to use 'imagemagick' instead of
+ ;; 'imagemagick/stable' (see the comment for the "imagemagick" input).
+ #:disallowed-references (,imagemagick/stable)
+ #:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -135,7 +139,11 @@
texlive-wrapfig
texlive-xcolor))
(native-inputs
- (list imagemagick ;for "convert"
+ ;; imagemagick is added for "convert". The store item does not retain a
+ ;; reference to imagemagick, so it should be safe to use
+ ;; 'imagemagick/stable' instead of 'imagemagick'. This is enforced by
+ ;; the '#:disallowed-references' above.
+ (list imagemagick/stable
python-cython
python-html5lib
python-pytest))