aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-04-07 01:15:01 +0000
committerChristopher Baines <mail@cbaines.net>2023-04-13 17:34:28 +0100
commit1e5ef8763f7887886b00debca7f06d8ac42e7419 (patch)
treefe83f28ae3f7d8cc397c87143bb43f9cf1253d56 /gnu/packages/sphinx.scm
parent2ae84ecdd374717085f0442e460484904868dbd6 (diff)
downloadguix-1e5ef8763f7887886b00debca7f06d8ac42e7419.tar
guix-1e5ef8763f7887886b00debca7f06d8ac42e7419.tar.gz
gnu: python-breathe: Update to 4.35.0.
* gnu/packages/sphinx.scm (python-breathe): Update to 4.35.0. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm31
1 files changed, 20 insertions, 11 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index addf4393b2..40633b75c6 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -804,18 +804,27 @@ scientific documentation.")
(define-public python-breathe
(package
(name "python-breathe")
- (version "4.34.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "breathe" version))
- (sha256
- (base32
- "18fvphs1cb2cns9q82195fx7lmlwfikzwa10cczavpaax2jnh1xc"))))
+ (version "4.35.0")
+ (source (origin
+ (method git-fetch) ;git repo has tests
+ (uri (git-reference
+ (url "https://github.com/breathe-doc/breathe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hlcrhr533yjkz9ds83xnmn8h6z3r6vfzz7qrpy14n9j4ysyz59c"))))
(build-system python-build-system)
- (propagated-inputs
- (list python-docutils python-sphinx))
- (home-page "https://github.com/michaeljones/breathe")
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "tests"
+ (invoke "python" "-m" "pytest" "-v"))))))))
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-docutils python-sphinx))
+ (home-page "https://www.breathe-doc.org")
(synopsis "ReStructuredText and Sphinx bridge to Doxygen")
(description "This package is an extension to reStructuredText and Sphinx
to be able to read and render the Doxygen xml output.")