aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:53:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:53 -0400
commit1a6b88192dba4aae27bc56f848f2ec42fa3d2eb5 (patch)
treef5aa1db8446d34e5d01562e227e92ededce95c6f /gnu/packages/sphinx.scm
parentba8ab7a48153b6fc784f93804339bf82aacb4b15 (diff)
downloadguix-1a6b88192dba4aae27bc56f848f2ec42fa3d2eb5.tar
guix-1a6b88192dba4aae27bc56f848f2ec42fa3d2eb5.tar.gz
gnu: Remove python2-sphinxcontrib-websupport.
* gnu/packages/sphinx.scm (python2-sphinxcontrib-websupport): Delete variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm26
1 files changed, 3 insertions, 23 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 197e2da464..1ae6be40ca 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -470,32 +470,12 @@ builder does not support SVG images natively (e.g. LaTeX).")
`(#:tests? #f))
(home-page "https://sphinx-doc.org/")
(synopsis "Sphinx API for web applications")
- (description "This package provides a Python API to easily integrate
+ (description
+ "This package provides a Python API to easily integrate
Sphinx documentation into your web application. It provides tools to
integrate Sphinx documents in web templates and to handle searches.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-sphinxcontrib-websupport))))))
+ (license license:bsd-3)))
-;; 1.1.2 is the last version to support Python 2.
-(define-public python2-sphinxcontrib-websupport
- (package
- (inherit (package-with-python2
- (strip-python2-variant python-sphinxcontrib-websupport)))
- (version "1.1.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "sphinxcontrib-websupport" version))
- (sha256
- (base32
- "1z7fqra0xm1cdp8vvp80fcvnjlywym7bzz80m0liq7fz1zxvw08m"))))
- (arguments
- `(#:tests? #f
- #:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (delete 'sanity-check))))
- (propagated-inputs
- (list python2-six))))
(define-public python-sphinx-gallery
(package