aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/smalltalk.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-31 13:54:17 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-06-04 13:34:58 +0200
commit961a8f130275dc18cc8e602e0b2ab08b780eb46f (patch)
tree699f490264c1f019c56a706380f0d575410c27e6 /gnu/packages/smalltalk.scm
parent4a600ada5a79fbf3c04011452593d2ee62d50a27 (diff)
downloadguix-961a8f130275dc18cc8e602e0b2ab08b780eb46f.tar
guix-961a8f130275dc18cc8e602e0b2ab08b780eb46f.tar.gz
gnu: smalltalk: Move 'zip' from 'inputs' to 'native-inputs'.
The 'zip' package is not in the references of 'smalltalk'. As such, it probably should be a native input, not a regular input. This can be confirmed by trying to cross-compile the 'smalltalk' package, without this commit. The configure script will ask to install InfoZIP. * gnu/packages/smalltalk.scm (smalltalk)[inputs]{zip}: Move to ... (smalltalk)[native-inputs]{zip} ... here. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/smalltalk.scm')
-rw-r--r--gnu/packages/smalltalk.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
index a572570b13..af4b7642ff 100644
--- a/gnu/packages/smalltalk.scm
+++ b/gnu/packages/smalltalk.scm
@@ -64,7 +64,8 @@
;; XXX: To be removed with the next release of Smalltalk.
("autoconf" ,autoconf)
("automake" ,automake)
- ("libtool" ,libtool)))
+ ("libtool" ,libtool)
+ ("zip" ,zip)))
;; TODO: These optional dependencies raise the closure size to ~1 GiB
;; from the current ~100 MiB, although some of them might be very
;; useful for end users:
@@ -81,8 +82,7 @@
("libffi" ,libffi)
("libltdl" ,libltdl)
("libsigsegv" ,libsigsegv)
- ("lightning" ,lightning)
- ("zip" ,zip)))
+ ("lightning" ,lightning)))
(arguments
`(#:phases
(modify-phases %standard-phases