aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/smalltalk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/smalltalk.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/smalltalk.scm')
-rw-r--r--gnu/packages/smalltalk.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
index 26f7ab2c76..c89e95316a 100644
--- a/gnu/packages/smalltalk.scm
+++ b/gnu/packages/smalltalk.scm
@@ -61,12 +61,12 @@
(patches (search-patches "smalltalk-multiplication-overflow.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
- ;; XXX: To be removed with the next release of Smalltalk.
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("zip" ,zip)))
+ (list pkg-config
+ ;; XXX: To be removed with the next release of Smalltalk.
+ autoconf
+ automake
+ libtool
+ zip))
;; TODO: These optional dependencies raise the closure size to ~1 GiB
;; from the current ~100 MiB, although some of them might be very
;; useful for end users:
@@ -79,11 +79,7 @@
;; - sqlite
;; - zlib
(inputs
- `(("gmp" ,gmp)
- ("libffi" ,libffi)
- ("libltdl" ,libltdl)
- ("libsigsegv" ,libsigsegv)
- ("lightning" ,lightning)))
+ (list gmp libffi libltdl libsigsegv lightning))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -146,15 +142,15 @@ such as ones for networking and GUI programming.")
"(VM_BUILD_STRING \\\"Built with GNU Guix\\\")"))
#t))))
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("dbus" ,dbus)
- ("freetype" ,freetype)
- ("libffi" ,libffi)
- ("libxrender" ,libxrender)
- ("mesa" ,mesa)
- ("pulseaudio" ,pulseaudio)))
+ (list alsa-lib
+ dbus
+ freetype
+ libffi
+ libxrender
+ mesa
+ pulseaudio))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no check target