aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorTimo Wilken <guix@twilken.net>2023-02-25 00:05:23 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-30 23:18:17 +0200
commit8c76eb61682a8c3347c739233c22c7bddb4027e8 (patch)
tree7b1ea39577e6e55914cf6b9b88c95501ec3bf3e9 /gnu/packages/shellutils.scm
parent6d0ad930206dccf382ec65c6504df51b5c798a34 (diff)
downloadguix-8c76eb61682a8c3347c739233c22c7bddb4027e8.tar
guix-8c76eb61682a8c3347c739233c22c7bddb4027e8.tar.gz
gnu: Add zsh-history-substring-search
* gnu/packages/shellutils.scm (zsh-history-substring-search): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 277d2d2647..e758340705 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2021 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
+;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -221,6 +222,34 @@ in Zsh intelligently.")
as you type.")
(license license:expat)))
+(define-public zsh-history-substring-search
+ (package
+ (name "zsh-history-substring-search")
+ (version "1.0.2")
+ (home-page "https://github.com/zsh-users/zsh-history-substring-search")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y8va5kc2ram38hbk2cibkk64ffrabfv1sh4xm7pjspsba9n5p1y"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("zsh-history-substring-search.plugin.zsh"
+ "share/zsh/plugins/zsh-history-substring-search/")
+ ("zsh-history-substring-search.zsh"
+ "share/zsh/plugins/zsh-history-substring-search/")
+ ("README.md" "share/doc/zsh-history-substring-search/"))))
+ (synopsis "ZSH port of Fish history search (up arrow)")
+ (description
+ "This is a clean-room implementation of the Fish shell's history search
+feature, where you can type in any part of any command from history and then
+press chosen keys, such as the UP and DOWN arrows, to cycle through matches.")
+ (license license:bsd-3)))
+
(define-public zsh-syntax-highlighting
(package
(name "zsh-syntax-highlighting")