aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-11-15 21:49:04 -0500
committerChristopher Baines <mail@cbaines.net>2022-11-17 12:00:31 +0000
commit024a98cb83c6b7d6bebbd56645bc6534d77f3ebc (patch)
tree40b2a0a6270cb97264f7b022bda4f972017eb202 /gnu/packages/shellutils.scm
parentcfeb51a6de11393aa275c0bf23b620572d2fd9ad (diff)
downloadguix-024a98cb83c6b7d6bebbd56645bc6534d77f3ebc.tar
guix-024a98cb83c6b7d6bebbd56645bc6534d77f3ebc.tar.gz
gnu: trash-cli: Use G-expressions.
* gnu/packages/shellutils.scm (trash-cli)[arguments]: Use G-expressions. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm51
1 files changed, 25 insertions, 26 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 40f33f5227..3fd98ecba8 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -382,32 +382,31 @@ between various shells or commands.")
"0hkn0hmwrag56g447ddqapib0s399a6b4a9wlliif6zmirxlww9n"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-path-constants
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc"))
- (coreutils (assoc-ref inputs "coreutils")))
- (substitute* "trashcli/list_mount_points.py"
- (("\"/lib/libc.so.6\".*")
- (string-append "\"" libc "/lib/libc.so.6\"\n"))
- (("\"df\"")
- (string-append "\"" coreutils "/bin/df\""))))))
- (add-before 'build 'fix-setup.py
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (mkdir-p bin)
- (substitute* "setup.py"
- (("add_script\\('")
- (string-append "add_script('" bin "/" ))))))
- ;; Whenever setup.py is invoked, scripts in out/bin/ are
- ;; replaced. Thus we cannot invoke setup.py for testing.
- ;; Upstream also uses pytest.
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'patch-path-constants
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libc (search-input-file inputs "lib/libc.so.6"))
+ (df #$(file-append coreutils "/bin/df")))
+ (substitute* "trashcli/list_mount_points.py"
+ (("\"/lib/libc.so.6\".*")
+ (string-append "\"" libc "\"\n"))
+ (("\"df\"")
+ (string-append "\"" df "\""))))))
+ (add-before 'build 'fix-setup.py
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (substitute* "setup.py"
+ (("add_script\\('")
+ (string-append "add_script('" bin "/" ))))))
+ ;; Whenever setup.py is invoked, scripts in out/bin/ are
+ ;; replaced. Thus we cannot invoke setup.py for testing.
+ ;; Upstream also uses pytest.
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
(native-inputs
(list python-pytest
python-parameterized