aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-16 17:07:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-16 17:07:35 +0200
commit1b4f6286df13505cd17b3060fe4da7f03f39ba59 (patch)
treef15b3e630c290911ff78f01ba7a219a4015ae985 /gnu/packages/shells.scm
parentc1303a914c172dc80166be22389e7032c5ea5e09 (diff)
downloadguix-1b4f6286df13505cd17b3060fe4da7f03f39ba59.tar
guix-1b4f6286df13505cd17b3060fe4da7f03f39ba59.tar.gz
gnu: scsh: Use a search path.
* gnu/packages/shells.scm (scsh)[source]: Add patch. [native-search-paths]: New field. * gnu/packages/patches/scsh-nonstring-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 128e557a21..0c8cbf3f4c 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
-;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
@@ -612,7 +612,8 @@ use of experts and novices alike.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))))
+ "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))
+ (patches (search-patches "scsh-nonstring-search-path.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -631,6 +632,11 @@ use of experts and novices alike.")
(list scheme48 scheme48-rx))
(native-inputs
(list autoconf automake))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "SCSH_LIB_DIRS")
+ (separator " ")
+ (files '("share/scsh-0.7")))))
(home-page "https://github.com/scheme/scsh")
(synopsis "Unix shell embedded in Scheme")
(description