aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2023-10-20 16:40:22 +0100
committerArun Isaac <arunisaac@systemreboot.net>2024-02-22 13:02:42 +0000
commite5ae409276412927a7aca905bc49f1591b80a5e4 (patch)
treec1c6d2153a66556d5836fae4c405b5e8fc6ddcf6 /gnu/packages/serialization.scm
parent127db3f844bf06a7957b52226a3fc6acbcef533d (diff)
downloadguix-e5ae409276412927a7aca905bc49f1591b80a5e4.tar
guix-e5ae409276412927a7aca905bc49f1591b80a5e4.tar.gz
gnu: python-ruamel-yaml: Update to 0.18.6.
* gnu/package/serialization.scm (python-ruamel-yaml): Update to 0.18.6. (python-ruamel.yaml-0.16): New variable. * gnu/packages/package-management.scm (conda)[inputs]: Replace python-ruamel.yaml with python-ruamel.yaml-0.16. * gnu/packages/backup.scm (borgmatic)[inputs]: Replace python-ruamel.yaml with python-ruamel.yaml-0.16. * gnu/packages/python-xyz.scm (dynaconf)[inputs]: Replace python-ruamel.yaml with python-ruamel.yaml-0.16. Change-Id: Iff9eeeae043c9547d93a6c780f0c30bd760490d9 Change-Id: I43cad7e3936f62d209fbba7e86b93519cfc1c1ba Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index cceef41a2a..331fae80cf 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -745,14 +745,14 @@ includes the following features:
(define-public python-ruamel.yaml
(package
(name "python-ruamel.yaml")
- (version "0.16.13")
+ (version "0.18.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ruamel.yaml" version))
(sha256
(base32
- "0hm9yg785f46bkrgqknd6fdvmkby9dpzjnm0b63qf0i748acaj5v"))))
+ "06rimidc9nb3i3r90n3a1zwf0qxw24zqykb3wpxwd1p72yifc9wb"))))
(build-system python-build-system)
(native-inputs
(list python-pytest))
@@ -771,6 +771,18 @@ and has round-trip loaders and dumpers. It supports comments. Block
style and key ordering are kept, so you can diff the source.")
(license license:expat)))
+(define-public python-ruamel.yaml-0.16
+ (package
+ (inherit python-ruamel.yaml)
+ (version "0.16.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ruamel.yaml" version))
+ (sha256
+ (base32
+ "0hm9yg785f46bkrgqknd6fdvmkby9dpzjnm0b63qf0i748acaj5v"))))))
+
(define-public python-ruamel.yaml.clib
(package
(name "python-ruamel.yaml.clib")