aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorAlexey Abramov <levenson@mmer.org>2023-04-15 08:13:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-03 12:36:08 +0200
commit9b9883c7730606a616f63e1a4a35b9735be5e9f6 (patch)
tree6614e58f0a995a9d27e4cd91bfa669e0cf2cffad /gnu/packages/serialization.scm
parent0abde609f277eccca36a5ee3b58e972ca0c2afac (diff)
downloadguix-9b9883c7730606a616f63e1a4a35b9735be5e9f6.tar
guix-9b9883c7730606a616f63e1a4a35b9735be5e9f6.tar.gz
gnu: Add libfyaml.
* gnu/packages/serialization.scm (libfyaml): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index df9e8fd7a9..39954d6764 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -436,6 +437,33 @@ in which the loaded data is arranged in memory.")
(home-page "https://github.com/tlsa/libcyaml")
(license license:isc)))
+(define-public libfyaml
+ (package
+ (name "libfyaml")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pantoniou/libfyaml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "002g0grddfi5y42lq06zj8266rf7h27wq76sr598ad5pxllx3y3g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ pkg-config))
+ (home-page "https://github.com/pantoniou/libfyaml")
+ (synopsis "YAML version 1.2 and JSON parser and writer")
+ (description "Libfyaml is a YAML parser and emitter, supporting the latest
+YAML spec and passing the full YAML testsuite. It is designed to be very
+efficient, avoiding copies of data, and has no artificial limits like the 1024
+character limit for implicit keys.")
+ (license license:expat)))
+
(define-public yaml-cpp
(package
(name "yaml-cpp")