aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-24 18:50:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-24 19:49:04 +0200
commit0bb60ed3ee9184dc635382ddb674071f5e5cc4d2 (patch)
treeb92259ba55f3fe6899fb37680a99ed4bde059403 /gnu/packages/serialization.scm
parent93d95bb843b01388978729e0d00d261f45fc49af (diff)
downloadguix-0bb60ed3ee9184dc635382ddb674071f5e5cc4d2.tar
guix-0bb60ed3ee9184dc635382ddb674071f5e5cc4d2.tar.gz
gnu: cereal-1.3.0: Update doctest.h.
* gnu/packages/serialization.scm (cereal-1.3.0)[native-inputs]: Add gcc-10 and the sources of the cereal package. [arguments]: Add a phase to replace the included doctest.h with the variant from the cereal sources; disable -Werror. [source]: Delete included doctest.h.
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index dc076909f9..df9e8fd7a9 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -195,17 +195,26 @@ such as compact binary encodings, XML, or JSON.")
(file-name (git-file-name "cereal" version))
(sha256
(base32
- "0hc8wh9dwpc1w1zf5lfss4vg5hmgpblqxbrpp1rggicpx9ar831p"))))
+ "0hc8wh9dwpc1w1zf5lfss4vg5hmgpblqxbrpp1rggicpx9ar831p"))
+ (snippet
+ '(delete-file "unittests/doctest.h"))))
(arguments
(substitute-keyword-arguments (package-arguments cereal)
((#:configure-flags flags #~'())
- #~'("-DSKIP_PORTABILITY_TEST=ON"))
+ #~'("-DSKIP_PORTABILITY_TEST=ON" "-DWITH_WERROR=OFF"))
((#:phases phases #~%standard-phases)
#~(modify-phases #$phases
+ (add-after 'unpack 'update-doctest
+ (lambda* (#:key inputs #:allow-other-keys)
+ (install-file (search-input-file inputs "unittests/doctest.h")
+ "unittests/")))
(add-before 'configure 'skip-sandbox
(lambda _
(substitute* "CMakeLists.txt"
- (("add_subdirectory\\(sandbox\\)") ""))))))))))
+ (("add_subdirectory\\(sandbox\\)") ""))))))))
+ (native-inputs
+ (list doxygen gcc-10
+ (package-source cereal)))))
(define-public msgpack
(package