aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:54:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:58 +0300
commitc15bda577112c1f9e0bd69c43111aec92f2c65a6 (patch)
treec2115b744c864ae7b8f089d921e72bfbb7c96f1f /gnu/packages/sequoia.scm
parent1395f85fe77edb47a6086ca2ed66ae752ed7f9e4 (diff)
downloadguix-c15bda577112c1f9e0bd69c43111aec92f2c65a6.tar
guix-c15bda577112c1f9e0bd69c43111aec92f2c65a6.tar.gz
gnu: Add sequoia-wot.
* gnu/packages/sequoia.scm (sequoia-wot): New variable.
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index ba5a74f002..9155093cd8 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -532,6 +532,38 @@ constraints on the signature into account.
This Guix package is built to use the nettle cryptographic library.")
(license license:lgpl2.0+)))
+(define-public sequoia-wot
+ (package
+ (inherit rust-sequoia-wot-0.8)
+ (name "sequoia-wot")
+ (arguments
+ (substitute-keyword-arguments (package-arguments rust-sequoia-wot-0.8)
+ ((#:install-source? _ #t) #f)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'install 'install-more
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share (string-append out "/share"))
+ (man1 (string-append share "/man/man1")))
+ (for-each (lambda (file)
+ (install-file file man1))
+ (find-files "target/release" "\\.1$"))
+ ;; TODO: Install _sq-wot.ps1, sq-wot.elv
+ (mkdir-p (string-append out "/etc/bash_completion.d"))
+ (mkdir-p (string-append share "/fish/vendor_completions.d"))
+ (copy-file (car (find-files "target/release" "sq-wot.bash"))
+ (string-append out "/etc/bash_completion.d/sq-wot"))
+ (copy-file (car (find-files "target/release" "sq-wot.fish"))
+ (string-append
+ share "/fish/vendor_completions.d/sq-wot.fish"))
+ (install-file (car (find-files "target/release" "_sq-wot"))
+ (string-append
+ share "/zsh/site-functions")))))))))
+ (description "An implementation of OpenPGP's web of trust.
+
+This Guix package is built to use the nettle cryptographic library.")))
+
(define-public sequoia
(package
(name "sequoia")