aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:38:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:58 +0300
commitb3ad82ff356fdcfa0c9f44735525e53f14f7f22a (patch)
treebb1bb6202df73df4a759a01b3a77eff971c5c9b4 /gnu/packages/sequoia.scm
parentedf97e4a56208e6becbbdd56a6d9330a0375d81f (diff)
downloadguix-b3ad82ff356fdcfa0c9f44735525e53f14f7f22a.tar
guix-b3ad82ff356fdcfa0c9f44735525e53f14f7f22a.tar.gz
gnu: rust-sequoia-openpgp-1: Update to 1.16.0.
* gnu/packages/sequoia.scm (rust-sequoia-openpgp-1): Update to 1.16.0. [source]: Remove snippet. [arguments]: Don't skip build. Add a feature-flag to use sequoia-openpgp/crypto-nettle. Add cargo-test-flags. [cargo-inputs]: Add rust-aes-0.8, rust-block-padding-0.3, rust-blowfish-0.9, rust-botan-0.10, rust-cast5-0.11, rust-cfb-mode-0.8, rust-cipher-0.4, rust-des-0.8, rust-digest-0.10, rust-eax-0.5, rust-ecb-0.1, rust-ecdsa-0.16, rust-ed25519-1, rust-ed25519-dalek-1, rust-generic-array-0.14, rust-getrandom-0.2, rust-idea-0.5, rust-md-5-0.10, rust-num-bigint-dig-0.8, rust-once-cell-1, rust-openssl-0.10, rust-openssl-sys-0.9, rust-p256-0.13, rust-rand-0.7, rust-rand-0.8, rust-rand-core-0.6, rust-ripemd-0.1, rust-rsa-0.9, rust-sha-1-0.10, rust-twofish-0.7, rust-typenum-1, rust-win-crypto-ng-0.5, rust-winapi-0.3, rust-x25519-dalek-ng-1. Replace rust-base64-0.13 with 0.21, rust-idna-0.2 with 0.3, Remove rust-backtrace-0.3, rust-itertools-0.10, rust-plotters-0.3, rust-unicode-normalization-0.1. [cargo-development-inputs]: Replace rust-criterion-0.3 with 0.4, rust-quickcheck-0.9 with 1, rust-rand-0.7 with 0.8, rust-rpassword-5 with 6.
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm93
1 files changed, 52 insertions, 41 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 45502a71c5..ad84904758 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -209,75 +209,86 @@ HKP protocol, and searching and publishing Web Key Directories.")
(define-public rust-sequoia-openpgp-1
(package
(name "rust-sequoia-openpgp")
- (version "1.6.0")
+ (version "1.16.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "sequoia-openpgp" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1mdprsijszkg2j6jk1iq7q1z9yikq598y12m5zbv94fs37xlx3qm"))
- (modules '((guix build utils)))
- (snippet
- ;; Remove dependencies on rust-crypto and win32-cng
- '(let* ((other-crypto-pkgs
- (list ;; rust-crypto
- "aes" "block-modes" "block-padding" "blowfish" "cast5"
- "cipher" "des" "digest" "eax" "ed25519-dalek"
- "generic-array" "idea" "md-5" "num-bigint-dig" "rand"
- "ripemd160" "rsa" "sha-1" "sha2" "twofish" "typenum"
- "x25519-dalek" "p256" "rand_core" "rand_core" "ecdsa"
- ;; win32-cng
- "eax" "winapi" "win-crypto-ng" "ed25519-dalek"
- "num-bigint-dig"))
- (pkgs-pattern (pk (string-join
- (list "^\\[dependencies\\.("
- (string-join other-crypto-pkgs "|")
- ")\\]")
- ""))))
- (substitute* "Cargo.toml"
- ((pkgs-pattern line name) (string-append "[off." name "]"))
- (("^crypto-cng =" line) (string-append "# " line))
- (("^crypto-rust =" line) (string-append "# " line))
- (("^\\[(target\\.\"cfg\\(windows\\))" line name)
- (string-append "[off." name)))))))
+ (base32 "1z0xl7hnm1p51pyhwdqyzcnl2dhzfjnvssz7hi15ps1hk4zzzvrh"))))
(build-system cargo-build-system)
(native-inputs
(list clang pkg-config))
(inputs
(list gmp nettle))
(arguments
- `(#:skip-build? #t
+ `(#:features '("crypto-nettle")
+ #:cargo-test-flags
+ (list "--release" "--"
+ ;; TODO: Figure out how this test is supposed to fail.
+ "--skip=parse::test::panic_on_short_zip")
#:cargo-inputs
- (("rust-anyhow" ,rust-anyhow-1)
- ("rust-backtrace" ,rust-backtrace-0.3)
- ("rust-base64" ,rust-base64-0.13)
+ (("rust-aes" ,rust-aes-0.8)
+ ("rust-anyhow" ,rust-anyhow-1)
+ ("rust-base64" ,rust-base64-0.21)
+ ("rust-block-padding" ,rust-block-padding-0.3)
+ ("rust-blowfish" ,rust-blowfish-0.9)
+ ("rust-botan" ,rust-botan-0.10)
("rust-buffered-reader" ,rust-buffered-reader-1)
("rust-bzip2" ,rust-bzip2-0.4)
+ ("rust-cast5" ,rust-cast5-0.11)
+ ("rust-cfb-mode" ,rust-cfb-mode-0.8)
("rust-chrono" ,rust-chrono-0.4)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-des" ,rust-des-0.8)
+ ("rust-digest" ,rust-digest-0.10)
("rust-dyn-clone" ,rust-dyn-clone-1)
+ ("rust-eax" ,rust-eax-0.5)
+ ("rust-ecb" ,rust-ecb-0.1)
+ ("rust-ecdsa" ,rust-ecdsa-0.16)
+ ("rust-ed25519" ,rust-ed25519-1)
+ ("rust-ed25519-dalek" ,rust-ed25519-dalek-1)
("rust-flate2" ,rust-flate2-1)
- ("rust-idna" ,rust-idna-0.2)
- ("rust-itertools" ,rust-itertools-0.10)
+ ("rust-generic-array" ,rust-generic-array-0.14)
+ ("rust-getrandom" ,rust-getrandom-0.2)
+ ("rust-idea" ,rust-idea-0.5)
+ ("rust-idna" ,rust-idna-0.3)
("rust-lalrpop" ,rust-lalrpop-0.19)
("rust-lalrpop-util" ,rust-lalrpop-util-0.19)
- ("rust-lazy-static" ,rust-lazy-static-1) ;; 1.4.0
- ("rust-libc" ,rust-libc-0.2) ;; 0.2.66
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-md-5" ,rust-md-5-0.10)
("rust-memsec" ,rust-memsec-0.6)
("rust-nettle" ,rust-nettle-7)
- ("rust-plotters" ,rust-plotters-0.3)
+ ("rust-num-bigint-dig" ,rust-num-bigint-dig-0.8)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-openssl-sys" ,rust-openssl-sys-0.9)
+ ("rust-p256" ,rust-p256-0.13)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rand-core" ,rust-rand-core-0.6)
("rust-regex" ,rust-regex-1)
("rust-regex-syntax" ,rust-regex-syntax-0.6)
+ ("rust-ripemd" ,rust-ripemd-0.1)
+ ("rust-rsa" ,rust-rsa-0.9)
+ ("rust-sha-1" ,rust-sha-1-0.10)
("rust-sha1collisiondetection" ,rust-sha1collisiondetection-0.2)
+ ("rust-sha2" ,rust-sha2-0.10)
("rust-thiserror" ,rust-thiserror-1)
- ("rust-unicode-normalization" ,rust-unicode-normalization-0.1)
+ ("rust-twofish" ,rust-twofish-0.7)
+ ("rust-typenum" ,rust-typenum-1)
+ ("rust-win-crypto-ng" ,rust-win-crypto-ng-0.5)
+ ("rust-winapi" ,rust-winapi-0.3)
+ ("rust-x25519-dalek-ng" ,rust-x25519-dalek-ng-1)
("rust-xxhash-rust" ,rust-xxhash-rust-0.8))
#:cargo-development-inputs
- ;; keep the development-inputs to allow running tests easily
- (("rust-criterion" ,rust-criterion-0.3)
- ("rust-quickcheck" ,rust-quickcheck-0.9)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-rpassword" ,rust-rpassword-5))))
+ (("rust-criterion" ,rust-criterion-0.4)
+ ("rust-quickcheck" ,rust-quickcheck-1)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rpassword" ,rust-rpassword-6))))
(home-page "https://sequoia-pgp.org/")
(synopsis "OpenPGP data types and associated machinery")
(description "This crate aims to provide a complete implementation of