aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-07-24 02:09:14 +0200
committerLudovic Courtès <ludo@gnu.org>2022-08-01 14:08:07 +0200
commit4f57da766812ce9ce0c9b924c04a6ad907022a24 (patch)
tree9c3e7c529ce45c69ed1a410ba44864a72b671397 /gnu/packages/security-token.scm
parentd790ec21e8530f230a371d542686f5caf956438e (diff)
downloadguix-4f57da766812ce9ce0c9b924c04a6ad907022a24.tar
guix-4f57da766812ce9ce0c9b924c04a6ad907022a24.tar.gz
gnu: Add cardpeek.
* gnu/packages/security-token.scm (cardpeek): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 84bd92b6f7..ef7085d35e 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2021 Ahmad Jarara <git@ajarara.io>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,12 +56,14 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages dns)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages networking)
#:use-module (gnu packages cyrus-sasl)
@@ -919,3 +922,48 @@ and assertion signatures.
libfido2 supports the FIDO U2F (CTAP 1) and FIDO 2.0 (CTAP 2) protocols.")
(license license:bsd-2)
(home-page "https://github.com/Yubico/libfido2")))
+
+(define-public cardpeek
+ (package
+ (name "cardpeek")
+ (version "0.8.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/L1L1/cardpeek")
+ (commit (string-append "cardpeek-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ighpl7nvcvwnsd6r5h5n9p95kclwrq99hq7bry7s53yr57l6588"))))
+ (inputs (list curl
+ gtk+
+ lua-5.2
+ openssl
+ pcsc-lite
+ readline))
+ (native-inputs (list autoconf
+ automake
+ `(,glib "bin") ;for glib-compile-resources
+ libtool
+ pkg-config))
+ (build-system gnu-build-system)
+ (synopsis "Tool to read the contents of various smart cards")
+ (description
+ "Cardpeek is a graphical tool to read the contents of ISO7816 smart cards.
+It is extensible with the LUA scripting language.
+
+It supports the following type of cards:
+@itemize
+@item Bank cards (VISA, MasterCard, CB and UK Post Office Account cards)
+@item Passports and the Belgian identity card
+@item Transport cards (Navigo, MOBIB, RavKav and VIVA cards)
+@item Older GSM SIM cards without USIM data
+@item Vitale 2 Health card
+@item Moneo Electronic purse card
+@item Driver Tachograph cards
+@item OpenPGP Cards (beta)
+@end itemize
+It also has limited support for Mifare Classic compatible cards (Thalys card)")
+ (license license:gpl3+)
+ (home-page "http://pannetrat.com/Cardpeek")))